Typing Japanese characters in Pages

Discussion in 'Mac Basics and Help' started by Lucky Linda, Jul 4, 2011.

  1. Lucky Linda macrumors newbie

    Joined:
    Jul 4, 2011
    #1
    I'm a teacher in Japan and need to make tests, etc. When I type Japanese characters and English in the same sentences in Pages, the spaces between the lines are uneven. Pages automatically widens the space between lines if there is a Japanese character in the line. This looks so unprofessional.

    Any ideas as to how can I fix this issue or how to communicate with Mac so they can fix it in their next update? I've already tried reducing the font size and changing the line spacing to no avail.

    Thank you to anyone who can help.
     
  2. garycurtis macrumors 6502

    Joined:
    Sep 15, 2010
    Location:
    Los Angeles & Northern California
    #2
    This isn't recent experience, but I worked in Japan for years. My operating system currently is OS Leopard and it comes with a variety of Kanji and Kana type fonts. Each offers line-spacing and character height choices.

    The way I have composed letters (English) with a few Kanji is to go to the keyboard selection on the top menu bar. I select the national flag and there appears a keyboard map with all the possible characters.

    If you use the free (Mac) utility program called Font Book (in you Applications folder) you can print out a complete character sample pallet for your font. Do that, then compare line spacing with various English point sizes in various fonts to find fonts that balance (in vertical or 'X height) and choose those fonts for your printed text. You can ask the question to book designers if you go to a website like 'Smashing Magazine' or 'Friends of Type' or 'Design Observer'. Professional graphic designers hang out on those sites and I've seen discussions before about Japanese script.
     

Share This Page