Typing not smooth on browsers.

Discussion in 'iPhone' started by 012512, May 25, 2013.

  1. 012512 macrumors newbie

    May 25, 2013
    Hi. Hello guys, I'm new to this forum and I hope you to bear with my question.

    Whenever I type on the text field such as this forum, i am experiencing lag or freezing of the unit and the keyboard. You cannot anticipate the way it functions while you type. Let's say you type the word "functional". You can type it on your screen because you are already used to type on the keyboard. The insertion point is freezing for a while unless you are done typing or else. This happens especially on all the browsers.

    My phone is iphone 4, ios 6.1.2. Thank you.
  2. wesk702 macrumors 68000


    Jul 7, 2007
    The hood
    Probably because the i4 is starting to get a little long in the tooth.
  3. ThatsMeRight macrumors 68020

    Sep 12, 2009
    Yep, iPhone 4 is years old by now and the chance that the iPhone 4 will be discontinued this year is like 90%.

    It is just running very new software on very old hardware. ;)
  4. Ajones330 macrumors 6502a


    Jul 9, 2008
    SEC Country
    Exactly, think this is the last go around with the iPhone 4. Depending on your carrier you may be eligible to trade it in for a newer device depending on your upgrade eligibility because it will only get worse...
  5. TacticalDesire macrumors 68020


    Mar 19, 2012
    It's because the iPhone 4 is 3 years old now. That's a long time in smartphone years. What's concerning is that there's someone signing a two year contract for one this very minute. It'll be 5 years old when they're done with it!
  6. lordofthereef macrumors G5


    Nov 29, 2011
    Boston, MA
    IME it has nothing to do with the 4. I have experienced this, to some extent, on every iOS device I have ever used long term. This would include every iPhone, and some iPads. It's iOS, or Safari, or a combination of the two.
  7. rocknblogger macrumors 68020


    Apr 2, 2011
    New Jersey
    If you have your bookmarks synced via iCloud, turn it off in settings>>> iCloud. Especially if you have a lot of bookmarks, it will make safari feel like and old dog.

Share This Page