typophone 4 white 'X' on lockscreen

Discussion in 'Jailbreaks and iOS Hacks' started by atomicrabbit, Dec 4, 2011.

  1. atomicrabbit macrumors member

    Joined:
    Oct 25, 2007
    #1
    Hey ppl,
    Since one of the more recent typophone updates, there is now a white 'X' on my lockscreen. It's been pissing me off to no end.
    [​IMG]
    Annoying White X

    Not to mention that one of the updates added some ugly blue-ish background as the default background instead of the black background that was before. This background was persistent -- even after changing the file in style.css, it would still show up during an incoming call. It was hideous. The only thing that got rid of it was deleting the LockBackground.png file.
    [​IMG]
    Ugly blue persistent background

    Anyway, back to this mysterious white X. I only realized it was from typophone when I updated typophone on my wife's iPhone too. The same white X appeared. What's odd is disabling the typophone theme in Winterboard does not get rid of the X. So this means that there's something more low-level going on here.
    [​IMG]
    Typophone 4 disabled

    Only uninstalling Typophone got rid of the white X and everything goes back to normal.
    [​IMG]
    Typophone 4 uninstalled

    After some time, I also noticed that this white X is not just a visual issue. After accidentally pressing it (because it's so close to the slider), it's actually a play/pause button. WTF?!?!

    Here is everything I've noticed with the recent updates to typophone:
    • ugly annoying white X -- :mad: (that also acts as a play/pause button)
    • lockscreen slider is harder to press (most likely because of the white X overlapping it)
    • The default background is beyond ugly and annoying to get rid of
    • The lockscreen audio controls no longer appear (double-press home button)
    • The error messages (like when you type an incorrect passcode) have been re-styled and they look hideous.
    • The background when an incoming call comes in is the ugly blue default background (even though I've changed the background in style.css) -- deleting the blue image using iFile is the only way to get rid of it.

    I don't know who has taken over updating typophone (i'm pretty sure the original creator stopped updating it a while ago), but whoever he/she is, they're screwing up this (once) fantastic theme.

    Does anyone know how to at least get rid of the white X and get the audio controls back on the lockscreen? I have a feeling it might have something to do with the new Clock hide tweak that is integrated right into the typophone installation (Typophone ClockHide), but I'm not sure
     
  2. atomicrabbit thread starter macrumors member

    Joined:
    Oct 25, 2007
  3. giant11 macrumors newbie

    Joined:
    Dec 1, 2011
    #3
    Alright atomicrabbit. I had the same problem you had with my typophone 4 app. I was going crazy but you seemed to have narrowed down a lot for me. The problem lies within the built-in lockscreen clock hide with the typophone 4.

    It made so much sense to me after you found out that the X symbol plays music. Here is the way I fixed mine....well not really but its gone now.

    Typophone 4 should have an update on Cydia and that update is made specifically for us. They removed the dependency of the lockscreen clock hide with typophone 4. Once you update, the X symbol should be gone.

    Now go back to Cydia, and install Lockscreen Clock Hide by David Ashman and everything should be back to normal.

    Let me know if Cydia does not have an update for you so I can tell you how to fix it without the update.
     
  4. atomicrabbit, Dec 6, 2011
    Last edited: Dec 6, 2011

    atomicrabbit thread starter macrumors member

    Joined:
    Oct 25, 2007
    #4
    GREAT ODEN'S RAVEN!! THEY FINALLY UPDATED IT.. It's been almost 3 weeks since they included that stupid clockhide in the installation. That's way too long for the author/updater to find such a hugely, obvious bug.

    Thanks for the heads up, giant11. EDIT: Just want to point out that when I upgraded it, the installation seemed to cause an error bc (I assume) the built-in clock hide conflicted with the Lockscreen Clock Hide Dependency. After upgrading and respringing, all I did was reinstall typophone and that seemed to clear everything up.

    The update seems to have fixed all the issues except the blue background (which is easily fixable) and the stupid error msg:

    [​IMG]

    Thankfully, it's easily fixable by removing the following images from /var/stash/Themes.XXXXXX/Typophone 4.theme/Bundles/com.apple.springboard/
    • DeviceLockTitleViewRedBackground.png
    • DeviceLockTitleViewRedBackground@2x.png
    • DeviceLockTitleViewRedBackground@2x~iphone.png

    Then in /en.lproj/SpringBoard.strings, you'll see the following:
    Code:
    "TRY_AGAIN" = "
    Try again";
    "WRONG_PASSCODE" = "
    Error";
    Delete those lines. That should get rid of those hideous error prompts, the only problem is you have to do it every time they update Typophone :mad:
     
  5. Brownski macrumors member

    Joined:
    Nov 18, 2010
    #5
  6. atomicrabbit thread starter macrumors member

    Joined:
    Oct 25, 2007
    #6
    Hey Brownski... at least I'm not the only one who thinks the new maintainer is screwin' the pooch on many of the recent updates. It's actually shameful to the original author/creator.

    Don't get me wrong, keeping themes up-to-date and fresh is good -- his/her recent ones are definitely not good. I just hope some of these comments somehow get to him so that he doesn't screw more things up in the future.

    All-in-all, the most recent updates seem to get rid of the major issues -- it now uses Lockscreen Clock Hide instead of the built in clock hide. The only ting outstanding is the really ugly default blue background and the ridiculous error msg style that have to be manually changed after every update (unless the maintainer *hopefully* decides get rid of those -- *COUGH* *COUGH*). Although it's not too big a deal to change.
     

Share This Page