'ubd' (Ubiquity daemon) working overtime...?

Discussion in 'OS X Mountain Lion (10.8)' started by withnail, Oct 29, 2012.

  1. withnail, Oct 29, 2012
    Last edited: Oct 29, 2012

    withnail macrumors regular

    Joined:
    Feb 8, 2003
    #1
    I have seen a few threads where people have had a similar problem to what I'm about to describe, but they were all a bit dated and none of the prescribed remedies seemed to work for me. I'm wondering if perhaps someone has come up with something else that works...

    All of my Macs' (MBP, mini, and MBA) fans have been going crazy and when I do a top, I see that ubd (Ubiquity daemon) is chewing up CPU like mad. As a bit of background, I have iCloud active on all of them and use it to synch docs across Macs, so turning if off is not a viable option. When I check console to inspect the ubiquity.log, I see messages like this being generated:

    /Volumes/Stuff/joe/Library/Mobile Documents/.ubd/peer-A4D744D5-0F21-6C0A-575C-4E9FFB7D4332-v23/ftr/empty-0x0003000000000101' (No such file or directory)

    Something that I suspect is related to my problem is that on my Mac mini, I have an SSD as the boot/OS drive, and a larger-capacity HDD as the storage. When I set up my user account on that machine (a few iterations of OS X ago), I remember there being an option to create the user's home drive in an alternate location to /Users/username which is what I did so that I could store my documents on the HDD and use the faster SSD for OS operations.

    I see the above-mentioned error in the logs on my other machines too, and it seems that Apple might have a bug in OS X that is hard-coding the home directory. In other words, instead of referencing ~joe, which the shell would resolve to the correct path, it's retaining /Volumes/Stuff/joe/ as the home directory on the other machines, which is not correct, since I don't have that alternate home directory set up on those machines for my UID. I've tried using sudo on the other machines to make a dummy path on the machines where it doesn't exist, but the problem persists. Any ideas?
     
  2. withnail thread starter macrumors regular

    Joined:
    Feb 8, 2003
    #3
    Thanks, Loa! :)

    This is actually what I tried, and it generally works, but sometimes the fans will kick back on, signalling that I need to do it again...
     
  3. Loa macrumors 65816

    Loa

    Joined:
    May 5, 2003
    Location:
    Québec
    #4
    Hello,

    iCloud "just working" is just about an insult. There have been numerous problems like these folders and the keychain (and a new one for me, as explained in another thread), and Apple doesn't fix any of them...

    Shame.

    Loa
     

Share This Page