Ubuntu Mate PPC G5 Dual Core 2.0ghz

Discussion in 'PowerPC Macs' started by apple apple, Sep 16, 2016.

  1. apple apple macrumors member

    Joined:
    Jul 22, 2014
    #1
    I'm soooo excited! I hope this works right. I made a short video of me dinking around on my Powermac and uploaded it to youtube. Just me using firefox, vlc (I can view youtube on the webpage but I prefer vlc), messing around on Doom. Oh yeah, did the video capture on the same machine. I am currently using a radeon hd 4550, I may go with a 4770.

     
  2. swamprock macrumors 6502

    swamprock

    Joined:
    Aug 2, 2015
    Location:
    Michigan
    #3
    I can't get linux to play nice with my dual 2.0ghz G5. I think it's probably due to my Radeon 9600 card. Lots of stuttering and pauses, and complete slow-to-a-crawl window drawing when dragging a window. I may have to try another card. I do have a Geforce 5200, but we all know how nice those play with linux...
     
  3. LightBulbFun macrumors 6502a

    LightBulbFun

    Joined:
    Nov 17, 2013
    Location:
    London UK
    #4
    I have a Radeon 9600XT working nicely with my 2Ghz 7,3 (its my main box for when i need to Linux) I just have the mate debs installed for working Rendering. (I dont think i even have radeon.agpmod=-1 set) rocking ubuntu mate 16.04
     
  4. apple apple thread starter macrumors member

    Joined:
    Jul 22, 2014
    #5
    Thank you Dronecatcher.

    Swamprock May I suggest an el cheapo radeon hd 4xxx? They can be found on the fleabay for not much. One draw back though. I thought I had 3d acceleration working perfectly; turns out I am having a problem with wrong colors in some of the rendering. My inspiration Luigiburdo, posted about how to fix this on other forums; so I am reaching out to him now. I'm soooooo close. Of course as soon as I get pointed in the right direction I will post it here.

    LightBulbFun that is so cool, I thought that card was one of the problem children cards. I'm glad you got it working.
     
  5. pochopsp macrumors 6502

    pochopsp

    Joined:
    Apr 6, 2016
    Location:
    Napoli, city of sun and pizza!
    #6
    @apple apple I asked you to make a video of your amazing config, and there is it! thank you, very nice config which shows even an unsupported platform can do almost everything... there are so many apps for linux! :)
     
  6. swamprock macrumors 6502

    swamprock

    Joined:
    Aug 2, 2015
    Location:
    Michigan
    #7
    I tested mine by installing Jessie with Mate, and I also installed the Mate debs, and the symptoms I described occurred. *shrug* Not sure what happened, but I gave it a couple of tries with the same results.

    Unfortunately, my G5 is AGP only, and those cards are a bit too rich for my blood.
     
  7. LightBulbFun macrumors 6502a

    LightBulbFun

    Joined:
    Nov 17, 2013
    Location:
    London UK
    #8
    what was your window compositing set to? and did you try radeon.agpmode=-1 ? I really wish ATI Radeon X800XT/X850XT cards worked in PPC Linux I have a X850 XT Mac edition id love to give a spin in Linux.
     
  8. swamprock macrumors 6502

    swamprock

    Joined:
    Aug 2, 2015
    Location:
    Michigan
    #9
    Yeah, I tried setting agpmode to -1. I used Compton with various settings, but nothing seemed to solve the problem. Another strange problem I had was with installing Iceweasel/Firefox-ESR addons. Most wouldn't install, with a simple "There was an error with installng <addon>." Not sure what's going on with this machine. I even switched hard drives, memory, and two different monitors (DVI Cinema and ADC Cinema) with the same result. Weird.
     
  9. LightBulbFun macrumors 6502a

    LightBulbFun

    Joined:
    Nov 17, 2013
    Location:
    London UK
    #10
    you say ATI Radeon 9600 ie with out anything on the name? just wondering as i have a Radeon 9600XT. (with mine actually if i hook up my 23 inch ADC ACD it will go blank half way through boot up despite Linux still seeing it it works perfectly fine in the same OS but on my Mac Pro...) in regards to the FX5200 i do believe they finally got nvidia cards fully working in linux :)
     
  10. apple apple thread starter macrumors member

    Joined:
    Jul 22, 2014
    #11
    Well after hours and hours learning how to compile updated drivers from source to get working 3d acceleration I was extremely frustrated. I kept having weird colors on a 3d shooter "alien arena". Now this is not isolated to PPC. These open source video drivers have these problems with some cards on Intel PC's also. I even got to a point where I borked my video 2d acceleration. Not being a linux expert and thus not having the ability to fix what I had done, I just re-installed Ubuntu Mate (which is just a little more involved than an Intel PC install). Then the thought hit me... Why don't I just try another game? I tried out Open Arena which is an open source game using the Quake3 engine and turned all the video settings on high. This is the result.



    Don't know why the other game gave weird problems, but oh well. I'd love to try out Doom 3. Just not sure if I want to go through all the hassle.
     

Share This Page