Uh oh...I can't make your phone call Siri

Discussion in 'iPhone' started by RickG, Oct 21, 2016.

  1. RickG macrumors regular

    Joined:
    Feb 8, 2011
    #1
    my new 7plus unlocked phone: Siri wont make a call for me- can't seem to figure out- could it be something to do with my ATT sim card- otherwise phone seems to be working fine?? help
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
  3. RickG thread starter macrumors regular

    Joined:
    Feb 8, 2011
    #3
    Siri starts to make the call then she says " uh oh i can't make your phone call" - ok I went out to apple store as no one could figure this out the first guy could not figure it out either- he turned Siri on and off and then asked me to turn phone and on- no fix - then told me the wait is about 1 hour and 45 min- or I can go call the 800# - I asked if I could talk to manager and he came over and tried a bunch of stuff and was stumped also- couldn't fix it- he took the phone into the back to head genius and said i had to rest the phone- he held the power button and volume down and rest the phone- that erased all my wifi pass codes and other stuff but siri no works- he said they had had several phone this has happened to- I'm up and running now and siri working good
     
  4. rijc99 macrumors 6502a

    rijc99

    Joined:
    Apr 27, 2015
    Location:
    FEMA Region 9
    #4
    Not sure why a hard reset via the power and volume down would wipe your wifi passwords and other stuff. Are you sure he didn't reset your network settings?
     
  5. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #5
    He would have had too to lose wifi info, which btw has never fixed a single problem for me and is one of the most annoying things to do esp. with iCloud.
     
  6. Phuq macrumors newbie

    Joined:
    Nov 18, 2016
    #6
    Turn off Dial Assist, test, then turn it back on.
     
  7. mgamboa macrumors newbie

    mgamboa

    Joined:
    Feb 23, 2017
    #7
    --- Post Merged, Feb 23, 2017 ---
    I had the same problem just before i uploaded this comment. What i did is that i turned siri off and then back on again, and it worked for me. Hope it does for you too.
     
  8. Eastside Rob macrumors newbie

    Eastside Rob

    Joined:
    Apr 30, 2017
    #8
    I had the same problem, but turning off the phone completely (not just rebooting it), and turning it back on after a minute fixed it. Previously, I went through Apple phone support with no success and a Genius Bar appointment, at which they concluded that the issue was corrupted software and that the only solution was a factory reset and a reinstallation of all my apps and data. We couldn't even do a reinstall from my iCloud backup, they said, because it would reinstall the software glitch again. I was at the Apple Store for my third appointment on this issue, with an external hard drive in tow so that we could drag my data off the iPhone before we reset the machine. On a hunch, the tech did some diagnostics that showed that my RAM clock speed was off. He asked me how often I shut my iPhone off. I told him "never," but that I reboot it from time to time, but he said it's not the same thing in terms of the iPhone's allocation of RAM. Turning it off and on a minute later did the trick — and saved me from having to spend much of my weekend resetting up all the apps and data on my iPhone. Incredibly simple solution for a problem even the first two Apple support guys couldn't solve.
     
  9. Weiser878 macrumors regular

    Joined:
    Sep 9, 2009
    #9
    I know this is an old thread but I just started having this same problem on my 7 with 11.2 beta installed.

    Turning off dial assist in settings/phone solved the issue. I’ve since turned it back on and Siri is working again.
     

Share This Page