UiTableview styles not applied

Discussion in 'iOS Programming' started by ilx.mac, Jun 30, 2009.

  1. ilx.mac macrumors member

    Joined:
    Mar 10, 2009
    #1
    hi there,

    i have attached two screen shot. The picture1 shows the style applied for the tableview. While i scroll down to see the data, the style are gone (please see picture 2). Any help would be greatly appreciated.

    Thanks in Advance!:)
     

    Attached Files:

  2. Luke Redpath macrumors 6502a

    Joined:
    Nov 9, 2007
    Location:
    Colchester, UK
    #2
    How are we supposed to help you without source code?
     
  3. ilx.mac thread starter macrumors member

    Joined:
    Mar 10, 2009
    #3
    Hey Luke,

    I have fixed the issue all by my self, by increasing the tableview size in IB.

    Thanks.
     
  4. ilx.mac thread starter macrumors member

    Joined:
    Mar 10, 2009
    #4
    How to set the size of the tableview through code? Can some one help me on this?

    Thanks in advance!
     
  5. jnic macrumors 6502a

    Joined:
    Oct 24, 2008
    Location:
    Cambridge
    #5
    Code:
    tableView.frame = CGRectMake(x, y, width, height);
     
  6. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #6
    You shouldn't really set the tableView frame to anything bigger than the screen frame. UITableView is a subclass of UIScrollView and so scrolls "within itself".
     
  7. Luke Redpath macrumors 6502a

    Joined:
    Nov 9, 2007
    Location:
    Colchester, UK
    #7
    OK, but something to bare in mind in future.
     

Share This Page