UK: How do we know if EDGE is working? Seems very SLOW.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by netdog, Nov 28, 2007.

  1. netdog macrumors 603

    netdog

    Joined:
    Feb 6, 2006
    Location:
    London
    #1
    I have a blue box with a white E inside most of the time, but the network seems very slow. I am certainly not getting anywhere near the sorts of speeds that people say EDGE should achieve. It is SLLLOOOOOWWWWWWW.

    This is in Westminster. Any ideas?
     
  2. skeen macrumors 6502

    Joined:
    Jul 12, 2007
    Location:
    London, England
    #2
  3. netdog thread starter macrumors 603

    netdog

    Joined:
    Feb 6, 2006
    Location:
    London
    #3
    410 kbps according to the site. Seems slow as molasses to me.

    According to this site, that speed is very good. I wonder if it is not the EDGE connection, but O2's handling of Internet transactions on their side that is slow.
     
  4. Kuffdam macrumors newbie

    Joined:
    Nov 1, 2007
    #4
    366.6kbps on T-mobile in the UK

    I think the speed is good... I was with Orange and moved.... Orange was terrible
     
  5. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #5
    All wireless net access is slow, including 3G when compared to anything else. Really it feels maybe twice as fast as dial-up.
     
  6. movielover21 macrumors newbie

    Joined:
    Nov 12, 2007
    Location:
    US
    #6
    It's expected, Edge is slow, reminds me of the painful days of dial-up.
     

Share This Page