UK - iPhone with BT Broadband???

Discussion in 'iPhone Tips, Help and Troubleshooting' started by m477h3w, Jul 21, 2008.

  1. m477h3w macrumors 6502

    Joined:
    Nov 9, 2007
    Location:
    Bristol, UK
    #1
    My Mac connects fine to my BT wireless broadband after entering the WiFi password, but for some reason it wont let my iPhone to connect, failing after I enter the password? Anyone have any experience of this? Is there some setting in the BT router that may be stopping other devices from connecting? :confused:
     
  2. steveapp macrumors member

    Joined:
    Jul 11, 2008
    #2
    Hi

    Its almost impossible to say without seeing, and I don't have BT Broadband either so forgive if this isn't helpfull but....

    There are three possibilities I can see...

    1. It isnt compatible with your iPhone - worst case here but unlikely.

    2. Your router has Mac address blocking enabled - I use this over wep, basically the router only allows you to connect devices it has listed by MAC address. Turn this off, allow your phone to connect, add it to the list and turn back on.

    3. Your wep password is wrong or problematic to use, I would try setting the router wep password to a simpler password, seeing if you can connect with that, then changing to a more complex one and trying - it might be your using an odd character or something in the password. If its the default password that came with the device that is unlikely but you should change it anyway :)

    Good luck

    Stephen
     
  3. ay98182 macrumors member

    Joined:
    Oct 8, 2007
    #3
    Which version of the iPhone/which firmware are you using?

    I've been using the first gen iPhone (running firmware 1.1.4) on BT Wireless Broadband at my friend's flat, and it works absolutely fine. I haven't tried my new iPhone 3G there yet, but there shouldn't be anything to stop it connecting.

    I know this sounds a bit patronising, but are you sure you're inputting the password correctly? It's harder to type on the iPhone and it doesn't show what you've put in lol (also remember that the password is probably case sensitive and the iPhone turns off capital letters after each letter you type, so you have to keep pressing the little arrow button)

    I hope this helps!
     
  4. Aggamemnon macrumors member

    Aggamemnon

    Joined:
    Nov 24, 2005
    Location:
    Bath
    #4
    I have a BT Homehub and an iPhone and it works for me.
     
  5. andimaciphone macrumors member

    andimaciphone

    Joined:
    May 9, 2008
    Location:
    Hereford,UK
    #5
    Works with two home hubs

    My brother in law and I both have home hubs.

    We also both have iPhones, mine is first gen,his is 3G.

    Both are running 2.0 firmware.

    Both our phones work with both of our home hubs.

    My daughters iPhone also works with both and she is still running 1.1.4 on a first gen.

    I think like previous posters have said check that you have typed your password correctly.
     
  6. moabon.rob macrumors member

    Joined:
    Jun 8, 2007
    Location:
    Cardiff, UK
    #6
    If it's a Home Hub you have, then it certainly wouldn't be MAC address filtering causing any issues, as the Home Hubs (shockingly) don't have any options for filtering by MAC address!
     
  7. Chris Bangle macrumors 6502a

    Joined:
    Apr 3, 2006
    Location:
    UK
    #7
    I think BT broadband routers have a limit to how many devices can connect to it, I always used to have to choose between my PDA or My Wii. There were about 6 devices previously connected to it. I never solved the problem because I moved to Sky and got a new router and got my iphone and never I connect my Wii up.
     
  8. m477h3w thread starter macrumors 6502

    Joined:
    Nov 9, 2007
    Location:
    Bristol, UK
    #8
    Wow, thank you so much for all the help! I was asking the question for my Dad, and I have a strange feeling he may have entered the password incorrectly :rolleyes: I was sure I had used my iPhone with a Home Hub before no problem. I will let you know if it was the password :D
     
  9. m477h3w thread starter macrumors 6502

    Joined:
    Nov 9, 2007
    Location:
    Bristol, UK
    #9
    Well it was a simple password issue. He was entering his Mac password rather than the Wireless Key on the back of the Home Hub :rolleyes: It's always the simple problems. Thanks again!!! :D
     

Share This Page