ultrasn0w "no service" or "sim error" on iPhone 4?

Discussion in 'Jailbreaks and iOS Hacks' started by thadoggfather, Oct 25, 2010.

  1. thadoggfather Suspended

    thadoggfather

    Joined:
    Oct 1, 2007
    #1
    ultrasn0w works great on my iphone 4 on 1.59.00 in Europe (on 4.0.1 with jailbreakme and now 4.1 with limera1n and preserved 1.59.00 baseband).

    But if I'm on an international train that goes around the country side, where there are big holes of not having service, sometimes the phone will get stuck in "no service" Airplane mode on and off won't help it or it'll sometimes get stuck on that 1 bar of signal without showing the service provider then it will say sim error if I flick airplane mode back and forth.

    AFAIK, it's happened on both 4.0.1 and 4.1.

    Otherwise, if I'm just in an area that has no service occasionally (not a drought of service), it works amazingly. And a reboot always fixes these problems.

    But, anyone else? Just curious :)

    Not the end of the world, and when I'm in the states, I don't need the unlock as I'm on AT&T but I still would like to know about it for clarification.

    Also, I didn't hactivate it. When I upgraded to 4.1, I had my AT&T sim in and it said phone activated and I could navigate around the home menu before I used limera1n to jailbreak and eventually ultrasn0w to unlock.
     
  2. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #2
    I had an identical problem running on T-mobile in the US and solved it by restoring the firmware, setting up as new and then re-jailbreaking and unlocking.
     
  3. vratnik macrumors newbie

    Joined:
    May 7, 2009
    #3
    no solution. Same here, and sometimes i need to reboot many times to get signal back. I am considering permanent unlock for 90 GBP.
     
  4. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #4
    ultrasn0w sometimes acts up abet! touchy you might say
     
  5. swoosh0217 macrumors 6502a

    swoosh0217

    Joined:
    Nov 20, 2007
    Location:
    NW
    #5
    I am having that same issue when I went to 4.1 so I went back to my stable 4.0
     
  6. Ikharo macrumors newbie

    Joined:
    Mar 14, 2011
    #6
    The same error

    I am having the same problem with my iPhone 4

    The first one was the iOS 4.1 and baseband 01.59, I always do the same thing, I restore my iPhone with original carrier (Movistar) then apply jailbreak and install ultrasnow, change the SIM (iusacell), works fine but suddenly "no service", sometimes i must reboot device *2 or 3 times for the signal back

    Now i do * same, I update iOS 4.2.1 and preserve baseband 01.59 (for unlock) the i install ultrasnow and the same thing happens, suddenly "no service"*

    Anyone can help me ?

    I read about this and found something like this **

    SIM status: KCTSIMSupportSIMStatusReady*

    This line i extract from my log is part of the error for this discussion*

    Help me please
     
  7. eddahlen, Mar 14, 2011
    Last edited: Mar 14, 2011

    eddahlen macrumors newbie

    eddahlen

    Joined:
    Nov 26, 2010
    Location:
    Eugene, OR
    #7
    Whenever this happens to me I turn Airplane Mode: On, Reboot, Airplane Mode: Off
     
  8. Leet Apple macrumors 6502a

    Leet Apple

    Joined:
    Nov 10, 2009
    Location:
    Canada
    #8
    That works for me to except i don't reboot
     
  9. johnnyturbouk macrumors 68000

    johnnyturbouk

    Joined:
    Feb 9, 2011
    Location:
    on the yellow [oled] brick road to tech nirvana.
    #9
    Where/how

    I brought my iPhone brand new on box
    From eBay - bargain- but it's locked
    to crappy three

    Need permanent unlock solution, three
    won't let me unlock as dude who sold the
    phone as unwanted upgrade
     
  10. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #10
    This is happening to me but I'm using my iPhone 4 with AT&T. Somedays my iPhone will just go insane and I need to reboot it every 15 minutes to get service.

    Airplane mode on/off wouldn't even work.
     
  11. still in school macrumors 6502

    Joined:
    Feb 21, 2009
  12. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #12
    I've read that only switching out the iPhone can be done. It has something to do with the sim tray part of the iPhone.
     
  13. Ikharo macrumors newbie

    Joined:
    Mar 14, 2011
    #13
    new discovery

    I restored my iphone with 4.2.1 iOS and BaseBand 01.59, because every 15 minutes, I had to reboot the phone to get signal.

    5 days have passed since I restored and there has been no problems with signal

    The only difference is that, I had not installed Cydia Apps.

    I suppose that some applications caused the conflict with ultraSnow
     
  14. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #14
    Even when not unlocked and using the iPhone with AT&T, I suffered from this.

    I restored my iPhone 4 back to 4.0 and so far it's working wonders. From 4.0-4.1, I never had the sim card issue. After upgrading to 4.2.1, it started happening.

    I think it may be because of the new version of Cydia.
     

Share This Page