Ultrasn0w "No Service" Problem

Discussion in 'Jailbreaks and iOS Hacks' started by iop53, Jun 26, 2009.

  1. iop53 macrumors newbie

    Jun 26, 2009
    I have successfully unlock both a 2G and 3G successfully using ultrasn0w. I have used the same procedure on a third 3G which it jailbrakes correctly. After installing ultrasn0w, rebooting, etc., I get the "No Service". It sees the available network and it lets me select the correct network, but it still will not connect.

    Any ides of how to fix this??
  2. iTouch macrumors 6502

    Sep 12, 2007
    Try turning it off then on or toggle airplane mode and see if that helps.
  3. jmann macrumors 604


    Dec 8, 2007
    bump on a log in a hole in the bottom of the sea
    You have to turn off 3G. And also make sure all the settings under MMS are cleared out.
  4. iop53 thread starter macrumors newbie

    Jun 26, 2009
    Still no luck

    I've toggled airplane modes, checked the message settings, but still no luck.

    This phone is not an ATT Iphone, it's from Europe, would that make any difference?
  5. imiloa macrumors newbie

    Jun 17, 2003
    I'm having the same problem with an AT&T phone. Ultrasn0w 0.6 installed, can see a list of carriers and select them. But still "no service" in system bar.

    Have tried all permutations of rebooting with 3G/Edge/phone(airport mode) on/off.

    Is there a CLI Ultrasn0w reset? eg: like "yellowsn0w -s" ???
  6. mullet macrumors regular

    Dec 8, 2003
    I was having a in issue with Ultrasn0w and an AT&T phone. For the first week I could have 3G on and have no issues what so ever. Then after realizing voicemail wasn't working and resetting my network settings my service would go in and out constantly. I found that uninstalling Ultrasn0w fixed the problem. I won't reinstall it until I travel to Turkey in August.

  7. jmeteor0525 macrumors newbie

    Jul 1, 2009
    No signal when 3G is OFF !

    I can only get ATT signal when I turn ON 3G, i tried rebooting and play around with the settings when 3G is off, but the signal won't get back up anyhow.. Is this normal..? I want to save some battery life and i dont get 3G network anyway since my phone is jailbroken and without contract.

    Anyone got an idea how i can get signal without turning on 3G??
  8. imiloa macrumors newbie

    Jun 17, 2003
    After some trial and error, I had both phone and edge/3G working briefly. Some things I've learned:

    -- Start from scratch: Restore system to clean 3.0 via iTunes.
    -- Run redsn0w immediately, without allowing rebooting phone to sync with iTunes.

    -- Only install Cydia. Icy install breaks Cydia.

    -- Install ultrasn0w (via Cydia) before doing anything else.

    -- Then wait a bit. I had "no service" for around 6 hrs, then gave up, did some work and checked back 10 hrs after ultrasn0w reboot. Found phone, edge, 3G working and stable.

    -- Don't restore the iPhone from backup in iTunes. Use as "new phone." You lose your SMS log, but the restore broke my edge/3G access both times I tried it.

    My guess is that ultrasn0w relies on a loophole that is some manner of "race condition" or sporadic vulnerability.

    Hopefully the devs will release an update that is more stable. But for now, the steps above may work for you as well.
  9. imiloa macrumors newbie

    Jun 17, 2003

    My iPhone 3G was still flaky and often yielding "No Service." After some more Googling, I found a random comment on a forum about old 5-volt SIM cards working more reliably for ultrasn0w'd iPhones than newer 3-volt SIMs.

    So I removed the Gevey-3G SIM cracker that I'd had in my iPhone since I first got it an unlocked it on the 2.2 firmware. This had been necessary in the yellowsn0w era. Being a pass-thru device, I figured its resistance would increase the voltage required by the SIM circuit.

    I removed the Gevey chip and rebooted. Now strong signal, with no No Service errors!

    Small miracles of logic...

Share This Page