umask for users logging in from windows


macrumors 6502a
Original poster
Jun 6, 2003
ok, so: i've got a file server running in-house here, a cranky old iMac running 10.2.8. i gave my intern a non-admin account, allowed him to log in from windows (he's a win-guy), and set up the share so that his home dir is /Library/WebServer/Documents/blah. we're doing some web stuff and i don't want a non-mac guy running around the system.

but whenever he saves anything into there, the permissions are locked down to his user account and i can't write to them. i tried changing the system umask, but it doesn't seem to work. the terminal's umask command reports the umask is 0, so shouldn't that mean any new files are automatically RW for everyone, not just their creator?

thanks in advance for any help.
IIRC (I am taking this from Linux usage and without a working example to hand) under the section for your share in smb.conf you can "force user" and "force group".

  force user  = sonofslim
  force group = skinnydads
This way all of the files created will appear to be created by you (I'll assume this works but you get the idea)

Reference : samba permissions, which also explains the default umask and remember that samba will perform it's own permission settings, so no need to fiddle with global system settings.

HTH - I'll try and check the config files I have set up in the office next time I am there to see exactly what I wrote.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.