UMAX scanner having problems HELP PLEASE

Discussion in 'Mac Accessories' started by KyGraphics, Jan 23, 2009.

  1. KyGraphics macrumors newbie

    Joined:
    Jan 23, 2009
    #1
    I am a newbie to macs first...
    I work doing typesetting work on the mac at the office, its got OS X 10.2.8
    as well as classic... we use pagemaker.

    My issue is our UMAX powerlook 1120 it used to work fine, scaned great. Something has happened, not sure what, and it would scan but VERY slowly, a normal page size at 300 dpi took 20 minutes, seriously when before it was 30 seconds to a minute tops.
    Now it doesn't scan at all, I use magic scan, it came with the scanner, and it starts, makes some noise, sounds bad though, brings up about an inch of the image, and pops up that the scanner has been disconnected.

    I have NO idea how to reinstall the scanner and software.
    I know how on a PC but Macs are a whole new ballgame for me.


    I have tried rebooting, unplugging, rebooting, plugging in, all sorts of combinations, No luck.


    Any help on this would be great.. my boss is getting annoyed that I have to scan on the PC and send it over to the mac via server.

    Thanks in advance.
     
  2. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #2
    That scanner is almost six years old. My guess is that it is probably on its last leg. I doubt a software reinstall is going to help.

    To reinstall the software, you just need to use the software CD that came with the scanner. Otherwise UMAX support may have a download for it in their support area, but with an obviously discontinued product it may be hard to find.
     
  3. KyGraphics thread starter macrumors newbie

    Joined:
    Jan 23, 2009
    #3
    I have been trying to figure out how old it was, I have noticed its hard to find information on it.
    I had a feeling it was just Old and dying, now I have to explain to my boss that Ive tried everything, its no use, and we just have to replace it...
     

Share This Page