Umbrella header 'starscream.h' not found

Discussion in 'iOS Programming' started by DenBeke, Jun 10, 2015.

  1. DenBeke macrumors regular

    Joined:
    Aug 11, 2011
    Location:
    Antwerp
    #1
    Yesterday I thought it was about time to write my first iPhone app using Swift 2 and Xcode 7 beta.
    I tried for a long time to import Starscream into my project until I discovered Cocoapods. I created a podfile and could install the framework into my Xcode project/workspace. I only had to convert the source to Swift 2 and fix some minor bugs for Swift 2. Everything worked fine, I could build for my own device and for the iOS simulator.

    After a computer restart today, this isn't the case anymore. I can compile for my own iPhone, but selecting an iOS Simulator device doesn't work anymore. I keep getting the following error:

    Code:
    /Users/Mathias/Library/Developer/Xcode/DerivedData/Liveblog-gffkwspwjvebzjfsmwwtxfpwnbct/Build/Products/Debug-iphonesimulator/Starscream.framework/Modules/module.modulemap:2:19: Umbrella header 'Starscream.h' not found
    I put the source code on Github: https://github.com/DenBeke/Liveblog-iOS-App
    Anyone who can help me?
     
  2. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    Go to the projects window in Xcode and tell it to delete the Derived Data for this project. Sometimes that fixes this kind of problem.
     
  3. DenBeke thread starter macrumors regular

    Joined:
    Aug 11, 2011
    Location:
    Antwerp
    #3
    Thank you, this worked for me!
    Though I had to ad the Starscream framework again in the project. Seems I still don't fully understand how to import modules ;)
     

Share This Page