Umm... needs a little help with OS X

Discussion in 'macOS' started by Hux, Sep 17, 2007.

  1. Hux macrumors newbie

    Joined:
    Aug 15, 2007
    #1
    Hi everyone, I'm not much of a poster here. I tend not to tale part in discussions, because I still consider myself a newbie and not very knowledgeable about Apple or their products (I simply don't have the funds to become an expert). However, I have a problem with OS X that I need some help with because my Applecare just expired.

    What happened was this. I needed some files for school, so I e-mailed them to myself to access at home. I got home, and when I clicked on mail I got the beach ball. Then everything froze up on me. So I figured I'd restart using control-:apple:-power. When it started up again it stayed in the grayed out startzone (you know, with the Apple logo, and the little spinny thing underneath?) So then I tried restarting it again. This time it again got to that point and then froze. I've had this problem before and it's always been a fairly quick fix as I recall, I just can't remember what I did to fix it. And Apple won't help me anymore. So if any of you could, I would greatly appreciate it.
     
  2. DesignerOnMac macrumors 6502a

    DesignerOnMac

    Joined:
    Jul 23, 2007
    #2
    Have you tried.....

    Have you put the install DVD into your and repaired and verified permissions?

    Did you max out your RAM? If you did did you buy good RAM? Take out any extra RAM and leave the Apple RAM in your computer.

    What computer are you using?

    I do not think your email is causing this problem.
     
  3. Hux thread starter macrumors newbie

    Joined:
    Aug 15, 2007
    #3

    1. I have not tried that yet. How do I boot it up from the install disc?

    2. I don't know what mnaxing out RAM means, so I don't think I did that.

    3. It's a Powerbook G4. I can't believe I overlooked putting that in my original post. It's about 3 years old now, I've never had any major problems with it, except for this thing that happens occasionally. Normally Applecare would have me reboot and hold down a bunch of keys during the reboot to reset stuff. I just can't remember what the keys were or what it was resetting (you never think your applecare's gonna run out 'til it does).
     
  4. RichardJohn macrumors member

    Joined:
    May 12, 2006
    #4
    Try holding Command (apple key) + Option + P + R when you're rebooting.
     
  5. Hux thread starter macrumors newbie

    Joined:
    Aug 15, 2007
    #5
    Ok, um two new questions.

    1) There's already a disc in my disc drive. Is there anyway for me to eject it at start-up?

    2) I now get this message in 4 languages telling me that I need to restart my computer. My spider-sense is really tingling with this one. Any ideas?

    Thanks for all your help so far. Just in case I can't fix it on my own, does anyone know of an affordable Mac repair shop in San Francisco? I'm a student and don't have a lot of available cash for an expensive computer repair. Thank you.
     
  6. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #6
    hold the mouse button on startup and the disc should eject on startup before you get to the apple logo.

    startup with the install disk by holding down 'c' on startup. choose your language and then select "disk utility" from the utilities menu. and then repair permissions and repair your disk from there. hopefully your mac should startup after this.

    the grey screen telling you to shutdown in a few languages is a kernel panic and is mostly got to do with bad hardware. you should also do a hardware check by starting up the install disk while pressing 'd'.

    sorry dont live in SF
     
  7. Hux thread starter macrumors newbie

    Joined:
    Aug 15, 2007
    #7
    Ok, first of all thanks to everyone that's helped me out, but I'm not out of the woods yet (it's been awhile because I had a weekend trip planned).

    So I got the movie dvd out, and put the OS X installer in. I started it up, and repaired all the permissions on my drive. I was going to repair disk in general, but I decided to backup stuff first. So I got my external hard drive, booted up from my external hard drive, and got about moving stufff over. The drive worked fine in target mode at first. Then I tried deleting my Caches. I know they don't take up a lot of room, but it had been awhile since I'd deleted them, and thought I'd try it. So I moved them to trash and emptied it. But it told me that a several caches couldn't be read or written.So I cancelled it. Then I tried to move my iTunes library over and it told me that a certain file (a free move file) could not be read or written. So I cancelled that as well. Then I tried to move my cashes out of the trash so I could empty it, and it froze up moving the files and I had to restart.

    When I was back in the installer, I went to select a start-up disk, but this time, my original mac hard drive didn't even come up on the list of available drives. So I picked my external and it got stuck on the step "waiting for local disks." So I decided to rstart and try again. Once again, my original hard drive didn't even show up, and the system's stuck on "waiting for local disks". Any ideas? Cause I'm at my wit's end at this point.
     
  8. Not-a-cliche macrumors regular

    Joined:
    Sep 24, 2007
    #8
    Repairing Permissions really doesn't do anything to help 99% of problems.
     
  9. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #9
    It seems that something is wrong with your filesystem.

    I don't expect it will work, but if you can, try booting in Single User mode, and fun fsck:

    - Boot while pressing and holding <COMMAND> <S> (you'll find a CLI based screen)
    (maybe reset PRAM to set the startup disk to your internal HD first...: boot while pressing and holding <COMMAND <OPTION> <P> <R>, until you hear the startup chime 3 time, then release the keys)
    - type "fsck -fy" and press <ENTER>
    - if fixes are attempted repeat steps above
    - if it reads: "the volume <your startup drive> appears to be OK", type:
    - "reboot" <ENTER>

    But, it could be you need to backup, and perform a clean installation... :(
     
  10. Hux thread starter macrumors newbie

    Joined:
    Aug 15, 2007
    #10
    Well, I finally got it working as a hard drive, and was able to move things over (I think the connector between my two hard drives got knocked out a little bit). So I wnt into dick utility and did a repair. But I got a pop-up telling me "the disk coud not be repaired underlying task reported failure on the exit (-9972)"


    Any ideas? Do I need to buy another disk utility programs (sorry, sorry, I guess we're supposed to call them "apps" now)? I'm kind of at a loss here.
     
  11. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #11
    Ok, so you have a complete backup now?

    If you do, insert the Mac OS X installation disk, boot from it, run Disk Utility and create a new partition on the HD.
    Then perform a nice new installation of OS X.
     
  12. Hux thread starter macrumors newbie

    Joined:
    Aug 15, 2007
    #12

    Well, I don't have a complete backup, just the important things (iTunes, documents, porn, etc.).

    So I have two questions. 1) How do you do that? And 2) won't that erase everything I've got on my computer, including all my settings?
     

Share This Page