Umm why??? And has this happened to anyone else?

Discussion in 'iPhone' started by ry23, Sep 22, 2014.

  1. ry23 macrumors member

    Jul 8, 2013
    So I received my 6+ this morning and in doing so, I switched the SIM card from my 5s to my 6+. I have no service on the 5s any longer, as it is a non-active sim, tho I still get wifi on the phone however. Now the strange thing is... Any time I get a phone call, my 6 and my 5s both ring. If I answer one, the other one stops ringing as tho I answered it. I would expect it to do the same with messages (especially iMessage due to the wifi being on on the 5s) but it doesn't. I don't receive any texts on the 5s, yet anytime I get a call on my 6 the 5s is ringing right along with it!!

    It's rather annoying.. Has anybody else experienced this phenomena? If so (and even if you haven't) does anybody have a fix for this?
  2. mrjoeyjiffy macrumors member

    Jun 19, 2009
    are they both on ios8? is this that thing like where you can answer calls on your ipad?
  3. wxman2003 Suspended

    Apr 12, 2011
    Do you also use google voice or something similar?
  4. TrueBlou macrumors 68040


    Sep 16, 2014
    I'm guessing you have iOS 8 installed. If you go to Settings-> General-> Handoff & Suggested Apps. You can disable it.
  5. cdinca macrumors 6502

    Jun 13, 2007
    I was trippin' balls when it happened to me. I didn't read up on iOS 8, so didn't know about handoff. Still don't quite get why I would want this.
  6. Angriff macrumors member

    Dec 28, 2013
    It isn't under handoff. It's under FaceTime settings: "iPhone Cellular Calls". Handoff doesn't control phone calls, it's a different thing entirely.
  7. Copefree macrumors member

    Sep 21, 2012
    Yep. When I get a call on my IP6+ now my iPad Air and (deactivated) IP5 ring too.:apple:
  8. wxman2003 Suspended

    Apr 12, 2011
    That would make sense. Thanks for pointing that out! Actually a good thing. Almost like wifi calling.

Share This Page