Un-Undoing - Finder

Discussion in 'macOS' started by Great Dave, Apr 24, 2008.

  1. Great Dave macrumors regular

    Joined:
    Oct 19, 2007
    #1
    So, I had saved some files from a network drive into my documents folder. I came home and on accident I removed Firefox from my dock. I hit command-z to see if it would put it back on my dock. Instead, the files in my docs 'poofed' and disappeared.

    They didn't go to my recycle bin, they are just gone. Can I get them back somehow? Where can I find them?

    Thanks!!

    * Edit *
    - The files are what I am wondering on how to get back.
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    drag Firefox from your applications folder onto the left side of the Dock and drag your Documents folder onto the right side of the dock.
     
  3. Great Dave thread starter macrumors regular

    Joined:
    Oct 19, 2007
    #3

    Thanks for the reply! But, I am wondering about the files that disappeared. I did get Firefox back into the dock.

    Where did the files go? I tried opening terminal and listing the doc directory, but I don't see them there either.
     
  4. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #4
    im not sure what you mean by this? usually the 'poof' effect only happens when you remove something from the dock. applications & stacks are only aliases so you can just drag them back if you remove them by accident.
     
  5. Great Dave thread starter macrumors regular

    Joined:
    Oct 19, 2007
    #5
    Sorry - I know I am not explaining it well.

    There is the documents folder next to the trash can on the dock. When I saved the files from the network, I saved them in the documents folder. You could see the icons of the files on the dock in the documents folder. When I clicked command-z, I saw the poof , (puff of smoke) in the docs folder next to the trash can. Looking at the documents folders in finder verifies that they are gone.

    Thanks!!
     
  6. coolbits macrumors member

    Joined:
    Nov 1, 2006
    #6
    That folder is still on your harddrive somewhere... you just deleted the shortcut in the dock...
    Check your home folder or use spotlight with some names of your files...
     
  7. Great Dave thread starter macrumors regular

    Joined:
    Oct 19, 2007
    #7
    I did try that, but spotlight didn't find them.

    Can you try this for me and see if it happens to you?

    1. Connect to a networked drive (or some shared folder on a computer on your network).

    2. Copy a copy files to your documents folder

    3. Command-Z (make sure that finder is active)

    4. files are gone
     
  8. karenflower macrumors 6502a

    karenflower

    Joined:
    Dec 7, 2007
    #8
    Did you try pressing Command-Z again? Sometimes this acts as a 'redo' action in the Finder.
     
  9. Great Dave thread starter macrumors regular

    Joined:
    Oct 19, 2007
    #9
    I did and I got an error message stating something like, 'network resources are unavailable'. ( Probably because it was trying to recopy the files from the network, but I was already at home.)
     
  10. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #10
    I think you didn't actually copy the files, I think you just added references to them on the network to your Dock. You have to be careful about how you drag files to folders on the dock. If the folder isn't darkened and doesn't have its name showing, you're just adding aliases to the files in the dock: that's why they appeared there.
     
  11. Great Dave thread starter macrumors regular

    Joined:
    Oct 19, 2007
    #11
    I thought of that, but I have done tests since then.

    Here is one of the tests.

    1. I copied over a word file
    2. Open Pages or Word and open the file within the program - If you open the file by clicking on the file, finder will not let you undo.
    3. After you see the contents, close it down.
    4. Then back in finder hit command-z
    5. File disappears - it is not in trash and I can't find it in terminal.

    I just think it is kind of bizarre, because it was written to my hard drive, but I can't find it.

    Thanks!!
     
  12. sanfrandan macrumors newbie

    Joined:
    Nov 8, 2010
    #12
    I had the same problem today, nearly 10 years later; since this post shows up as the first answer on Google, I am posting the simple solution here, found at this link:
    https://support.apple.com/en-us/HT201236
    You can then press Command-Shift-Z to Redo, reversing the undo command.

    That restored my files to the Finder folder!
     
  13. Tech198 macrumors G3

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #13
    Any icon u remove from the dock would just vanish in a puff of smoke... Just drag them back from the folder. When u drag to he dock, it crates an alais.. all that happens is when u vanish it, it just removes that alias, but the original file is still there
     
  14. bcave098 macrumors 6502

    bcave098

    Joined:
    Sep 6, 2015
    Location:
    Northern British Columbia
    #14
    This thread is nine years old. And clearly the OP was not talking about 'undoing' removing something from the dock.
     
  15. attis macrumors member

    Joined:
    Nov 18, 2012
    #15
    If this thread was nine years old in 2015, it is now - eleven years old - ! It is still relevant though and I feel for the OP, few seemed to understand what he was talking about.

    I too am 'a victim' of this phenomenon. I copied a bunch of files from a flash drive to my MPB. I then accidentally removed the 'Documents folder' when i tried to backup the newly copied files to our work NAS. By force of habit i hit cmd+z. That of course didn't restore the folder shortcut I just removed, but sent my recently copied files in to a cloud of smoke. There is no option to further undo or redo. The files are just gone. And I am certain they were copied to my drive since I looked at them in Photoshop after copying from the USB drive.

    Is there any way of prohibiting this or get the files back without copying from the original source again?
     
  16. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #16
    Time Machine may have had a chance to backup the files before you deleted them.
     
  17. T'hain Esh Kelch macrumors 68040

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #17
    Do you live in the future? Is Trump still president?
     

Share This Page