Unable to Access Password WiFi Networks?

Discussion in 'iOS Blog Discussion' started by MacRumors, Jun 30, 2007.

  1. MacRumors macrumors bot


    Apr 12, 2001

    One common area of confusion appears to be the ability to access Password Protected WiFi networks. Part of the problem is that the iPhone will gladly accept any password for the Wifi network without any particular error message if its wrong. Instead, you simply are unable to access Wifi, and the iPhone will keep defaulting back to EGDE.


    Note the "lock" icon next to 021J8

    Many routers use a Hex or ASCII string for the passcode to allow access to your Wifi network. This requires a small tweak in the settings. In my situation, my home network is run off an Actiontec router (Verizon FIOS) named "021J8". The Actiontec router has a Hex password which won't work on the regular iPhone WEP Password blank.

    Read More
  2. Frazzle macrumors regular

    Mar 1, 2007
    Then again, WEP is akin to having an unsecured network

    If memory serves, the latest tools have been able to break WEP within 20 minutes using an everyday laptop. Therefore, WEP security is no longer a form of security.

    Doesn't make this article less useful though. This works the same for WPA encryption? How's that work on the iPhone?
  3. Clix Pix macrumors demi-goddess

    Clix Pix

    Oct 9, 2005
    8 miles from the Apple Store at Tysons (VA)
    I had no problem last night in accessing my password-protected wireless network (WPA).....
  4. technicolor macrumors 68000


    Dec 21, 2005
    Havent had any problems

    So Arn you cant get on your home wifi at all?
  5. Chaszmyr macrumors 601


    Aug 9, 2002
    No such problems here. If i type the wrong password, it pops up saying the password was incorrect.
  6. Lixivial macrumors 6502a


    Jan 13, 2005
    Between cats, dogs and wanderlust.
    Interesting notation. Silly WEP, but even sillier Actiontec. I have a mild hatred toward Actiontec; a pile of rubbish it be.

    I had a problem with my 63-character WPA randomly generated pre-shared key. I tried it 8 ways from sunday and could not get it to work; I'm guessing I was making a typo somewhere -- it'd be nice if we could see what we were typing. I could have sworn I was typing it in properly, though. I temporarily lowered my key to a more manageable 21 characters and it's worked OK...

    Once I saw the keyboard pop up for the WPA key, I thought "Oh boy, this is gonna be fun!" :D
  7. aaronjudd macrumors newbie

    Jun 30, 2007
    The first time I added the iPhone to my network I nearly I tore my hair out, until I realized the keyboard seemed to be starting out in uppercase, and my wep password was all lowercase (plus numbers). I found that once I figured out the case entry, the wep password worked regardless of the selections I made for (you have a choice of wep-ascii/hex, or just wep). The second time I added an iPhone to my network everything was flawless and easy (with the touch of prior knowledge).
  8. elistan macrumors 6502a

    Jun 30, 2007
    Denver/Boulder, CO
    Sigh, I wish it were that easy for me. Sometimes I can't even get a list of wifi networks. Often I can connect just fine, and every once in a while (only twice now!) have I been able to use Safari over the wifi connection. Both times, after using the connection for a short while, all transmissions ceased and I once again was unable to view a list of wifi networks...
  9. twalkabout macrumors newbie

    Jul 17, 2002
    i use an airport express as a base station, and my iphone would not accept the ASCII equivalent password, i had to input the hex key. annoying considering it does not show you what you type in the password field in iphone, so you really have to be careful with entering it.
  10. dr_lha macrumors 68000

    Oct 8, 2003
    Its not akin to having an unsecured network at all. If my network was unsecured then anyone could use it. With WEP encryption it means that only those who really wanted to could break in, and I'm betting that's nobody around my way.

    Saying its not a form of security is rather like saying the locks on my house are not a form of security because someone with a brick can break into my house. Its all about stopping oportunists, rather than hardcore thieves (or hackers in the case of WiFi).
  11. Limey55 macrumors newbie

    Jun 30, 2007
    The WI-FI issue I see as a problem

    Any wifi device I have ever used, will allow me to enter the wifi SSID name and the WEP password ( or ASCII key ) without my wireless signal being set to broadcast. If the two above are correct, the connection is made and I am online.

    With the iPhone, if my router is not broadcasting the wireless SSID, then I do not get on. If I set my router to broadcast my wireless connnection, the iPhone sees it, I enter in the password and I am online. As soon as I turn brodcast back off on my router, the iPhone drops the signal.

    This, in my opinion, is a flaw in the iPhone. It should maintain the signal. I have 1 PC and 2 laptops in the family that do so with no problem.
  12. rdowns macrumors Penryn


    Jul 11, 2003
    No problems here at all.

    What I do find strange is that my desktop sees 4 networks whereas my iPhone sees 8. WTF?
  13. LizKat macrumors 68030


    Aug 5, 2004
    Catskill Mountains
    turn on SSID b'cast in router page; and on the iPhone, add DNS server addresses

    I have DSL with a Siemens Speedstream modem-router. I had to turn SSID broadcasting on in the router page before the iPhone could find the network. After it connected, I also had to stick the DNS server addresses for my service provider into the DNS space in the iPhone's page for info about the network I had connected to.

    And now, I am 100% totally totally beyond wildest dreams happy with my new iPhone. I live in a dead zone and activation was a pain in the neck even though I already had an existing ATT/Cingular account. You'd think the program would look at the billing zipcode, look at the phone exchange of the other phone and go "doh, well... just give her new phone a number in the same telephone exchange as the other phone and if she doesn't like it, give her one free number change and be done with it". But no, of course it asked some dumb question like "what is the [full] address of the primary place you will use the iPhone?"

    Doh. OUTSIDE MY DEAD ZONE HOUSE, hello???? Preferably in an ATT-towered turf so they don't cancel my swell "national" plan. I have a landline and two different "national" cell plans to keep my communications options open in a huge area of VERY spotty coverage by ANY carrier. Smile, NOT. The primary place I use the phones of either carrier is wherever I believe my call will bounce off their respective towers and not a "partnered" one. Naturally my activation required intervention by a human being... but both my ATT phones are now happily based in a town with ATT reception about 40 miles away. I drove over there to check out the phone and it's great. Net surfing on EDGE def sucks, though. I would do it to find out when a movie starts, maybe... !! Wifi works fine.

    But about the iphone, yes, now I am all smiles, it is way cool to WiFi my way through the news in my kitchen on something looks like a fancy iPod!

    I am in love with the designers, the engineers, the Quality Assurance dept, the packagers, the whole trip. And especially in love with getting to Albany (90 miles one way) on Friday and finding an Apple store full of sales people ready to process a hundred people in front of me out the door in less than 20 minutes. We all floated back to our cars carrying our iPhone bags as if we were dreaming! I am so freaking impressed with this launch!!!! Everything cool out of the box, no traffic hassles, beautiful day... I will go back to that Apple store again for "stuff" for my new toy; I had never been there before; it's really easy to get to from where I live.
  14. Lionheart macrumors regular


    Jun 29, 2007
    Tampa, FL
    Wifi and Actiontec Working, but...

    I love my Iphone. However, there are definitely some wifi connection issues.

    At home, I spent a while surfing on EDGE but thinking I was connected to my wifi because I had put in the password. It occurred to me that it should be much faster, and then I figured out the indicator system up top. If you haven't yet (I'm not much for reading manuals, as most of you, I'm sure) next to the ATT indicator is an E if you're on EDGE, or the familiar concentric half circles if you're on wifi.

    Anyway...as has been shared already, there was no indicator that my WEP password was not accepted...I thought it had taken it. But, after reading a bit in the forums here, I tried changing the password to ASCII and putting in my password, and that did the trick. Speed is phenomenal and I spent the night running down my battery watching YouTube. Actually was quite enjoyable.

    Another clue with the password entry, in case you haven't figured this out yet...just hold your finger down on the keyboard until you reach the key you want before releasing. It doesn't enter the keystroke until you release.

    So then...I went to church this morning and, being the consummate geek, had to try to connect to the wifi there. It took the password, and I got an IP address from the router (that's a sure way to find out if you're connected to your network...make sure your IP matches your router with the usual 192.168.x.x and not the default setting, which is much different). However, none of the web apps worked from that point on. Turned off wifi under Settings and EDGE kicked in and they worked. Turned wifi back on, renewed my lease, still no good.

    I'm hoping that they get an update out soon, since this seems to be an ongoing problem. Hope this helps somebody out there!

    Still....I LOVE my iPhone..did I say that?
  15. gothamgal macrumors newbie


    Jul 1, 2007
    iPhone MAC ID?

    Hi. I don't yet have an iPhone, but was wondering if it has a MAC address and how you can identify it? My home network is limited to only specified MAC addresses, so I won't be able to log onto my WiFi unless I "pre-allow" the iPhone.

    Has anyone had any experience with this?
  16. Anonymous Freak macrumors 601

    Anonymous Freak

    Dec 12, 2002
    Yes, every device with a network card (wired or wireless,) has a MAC address. Theoretically, every network interface has a different MAC (so an AirPort Extreme -n base station actually has 5 of them. 1 for the internet Ethernet, 1 for wireless, and 3 for the 3 LAN Ethernet ports,) but I have seen duplicate MAC addresses before. (I worked in Intel's server division, and had one case where the onboard NIC had the same MAC as a PCI NIC.)

    You can find out the iPhone's MAC address in its 'Settings', under 'General', then 'About'. Apple calls it the "Wi-Fi Address".
  17. note235 macrumors 6502a

    Jun 29, 2007
    thank you very much
    was using edge thought wifi
    surprisingly fast
  18. ToothLoz macrumors newbie

    Jul 1, 2007
    iPhone for Business? NOT!!!

    Disregard, I made my post in the troubleshooting forum... I couldn't make a new thread before...
  19. noriyori macrumors member

    Oct 31, 2006
    I have a problem of a different sort but similar in nature...

    I have no problems connecting to my password protected wifi at home and the unprotected networks at work, the coffee shop and my dad's house.

    but trying to connect to my friends unprotected belkin wifi network it says I'm connected and gives me an ip/shows the wifi connection at the top next to AT&T, but will not load any web pages/email/youtube.

    the network is running fine as I can connect and do everything on my MBP and his desktop pc.

    PS: his router is set up with all the factory settings.

    any clue?
  20. elistan macrumors 6502a

    Jun 30, 2007
    Denver/Boulder, CO
    Go into the IP settings of your wifi connection to the router. It probably has the router's IP as the DNS server. Try this - replace that with the DNS server of your friend's ISP (you'll need to get that from the router itself.)
  21. JonnyMo macrumors newbie

    Jun 30, 2007
    Fixed wifi issue--Modem Password Off!

    My iPhone refused to stay connected on my WEP password protected ActionTec gt701 DSL modem via wifi.

    I would get a good signal and then when I launched the browser, it would try to load the page, then the signal bars would go away and the Edge service would take over. I am very certain the correct password was entered as it all worked well on Friday when I bought the iPhone.

    I checked the DHCP addresses and it showed an IP address and Subnet mask only. No router or DNS.

    I then disabled the WEP password on my modem and relaunched Safari, on my iPhone, and I had instant fast wifi access. Great!

    And the DHCP addresses showed and IP address, Subnet mask and Router and DNS addresses!

    It seems like Apple has a software problem with the iPhone wifi password system. Hope they fix it soon.

    I'll keep my modem password free for a few days and see what the Apple folks say about all the wifi/Edge problems.
  22. elistan macrumors 6502a

    Jun 30, 2007
    Denver/Boulder, CO

    Got an update - got a new iPhone! I took the old one into the Apple store I bought it from, hooked up to their wifi and started browsing at the Genius Bar. It actually worked for a good while - longer than it ever had before. Stressed me out while it was working. The guy had suggestions like "Be patient, sometimes it takes a while to load," and "Perhaps you should bring in your Airport so we can look at that." And I KNEW that it stop working again as soon as I got home. He was just saying the usual things - what else could I expect when it was working right in front of us? Well a little time passed while he took care of some stuff, and JUST as he asked for my phone to get the serial number for the trouble ticket - IT STOPPED WORKING! Yay! He worked with it a while "... it dropped wifi... went to edge... hmm hmm..." and eventually said "Okay, we'll get you a new phone." Swapped the SIM, had to get the original box from the house since it has all the serial number and junk on it.

    Anyway, I've been hitting the 'net hard, and not a single issue. (Knock on wood.)
  23. exNavy macrumors newbie

    Jul 2, 2007
    Valley of the Sun
    Odd, no problems joining our protected network.
  24. cp2222 macrumors member

    May 10, 2006
    The day I brought mine home I input my wireless WPA2 information into my iPhone and it worked great! I ran some errands and came home and sure enough it was back on my wireless LAN again.

    Now after 2 days and a lot of messages popping up all the time about available wireless networks....I go home and I am on edge, not wi-fi. In fact, my wireless network doesn't even show up. I added it again and it connected just fine. Then I locked my phone -- waited a couple hours and opened it up and it is on edge again. I wait and wait thinking that it just going to connect in a few seconds, but to no avail.

    Looks like the iPhone OS network management doesn't really have it's memory down perfectly yet. I would say this is one of the strongest features of MAC OS X because in areas like where I live, there are generally 5-10 networks in range. Mac OS X always knows my home one and always chooses that first.
  25. Yankees 4 Life macrumors 6502a

    Jun 25, 2007
    College Station, Tx
    that problem you have is a router problem my friend, my router does the exact same thing, and it is annoying as hell. it drops my iphone coverage and makes me mad sometimes..

Share This Page