unable to access web from Macbook Pro via Netgear WGT624v3

Discussion in 'MacBook Pro' started by mburstin, Aug 12, 2007.

  1. mburstin macrumors newbie

    Joined:
    Aug 12, 2007
    #1
    I am having a strange problem on a brand-new Macbook Pro (2.4GHz with wireless N adapter). My router is a Netgear WGT624v3 router with the latest firmware with WPA encryption enabled.

    When connected to the router via wireless, I am able to SSH out from the Mac, but am unable to access the web or AIM/Yahoo messenger. I tried to fire up wireshark, and I see the machine obtain obtain DNS info for the remote web site, but it never connects. The machine is set up with boot camp, and everything works perfectly when booted into XP. I am also able to access my wireless router's web-interface from the Mac. Everything also works perfectly when I am plugged in via ethernet cable.

    I am able to use wireless from the machine in my office which uses WPA2 security, and I am able to connect when I connect to my old Linksys router which has only 802.11B support and WEP encryption. The machine is connected to the router because I can ssh out.

    Any ideas?
     
  2. bc1 macrumors newbie

    Joined:
    Dec 13, 2007
    #2
    I had same problem. I manually updated the router's firmware (to version 2.0.25) and that fixed it.

    Get the new firmware from here: http://kbserver.netgear.com/products/WGT624v3.asp
     
  3. beamer908 macrumors newbie

    Joined:
    Jul 15, 2008
    #3
    Wow, thanks for this! I switched from WEP and WPA and started running into all kinds of problems as a result of this. Is there a particular fix mentioned in any of those firmware upgrades that addresses some WPA incompatibility with OS X or other?
     

Share This Page