Unable to answer call - Sent to background?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by kAoTiX, Oct 14, 2008.

  1. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #1
    I recently experienced something rather strange. I had just sent someone a text message and as some of you may know, when you send a text message on a pay-as-you-go iPhone 3G you get your balance shown with a big 'DISMISS' button at the bottom.

    As I sent a message I received an incoming call but as I went to answer it my balance popped up with the big DISMISS button over everything. When I clicked the DISMISS button it went back to the home screen and backgrounded the incoming call. My phone was still ringing and vibrating but even when I manually went into the phone thinking it would be sitting there asking me to answer it actually let me dial a number at which point the incoming call stopped.

    Has anyone else experienced this or am I just being stupid? I've only had my iPhone for around 2 weeks now and I couldn't see anything about incoming calls getting sent to the background.

    Any help would be appreciated.
    Thanks
     
  2. wackymacky macrumors 68000

    wackymacky

    Joined:
    Sep 20, 2007
    Location:
    38°39′20″N 27°13′10″W
    #2
    I had three occasions when my phone did a very simular thing (ie an incomming call when I had SMS open and the phone would pehave as you describe). Updating the softwaren to 2.1 fixed it for me. I presume that you've already done this?
     
  3. kAoTiX thread starter macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
  4. ILBandit macrumors regular

    Joined:
    Sep 7, 2008
    #4
    Mine did a similar thing this morning, I wasn't in the texting screen though. I had just switched it to the vibrate mode, and it started vibrating like someone was calling me, but there was noting on the screen indicating a call was coming in. I switched it back to the "sound on" mode, and my default ringtone was ringing, like someone was calling me. But it didn't stop, I had to power the phone off to make it quit, has worked fine since then.

    I assumed it was just a little freak thing that happened, and nothing to worry about unless it starts doing it again.

    Also running the latest software.
     

Share This Page