Unable to boot into OSX after (trying) to dual boot with linux

Discussion in 'Windows, Linux & Others on the Mac' started by krahmaja, Jul 19, 2015.

  1. krahmaja macrumors newbie

    Joined:
    Jul 19, 2015
    #1
    Hello,

    it looks like I've gotten into a big mess and I'm searching for assistance. I was interested in dual booting Kali Linux on my macbook air and I followed this guide:

    http://docs.kali.org/installation/kali-linux-dual-boot-on-mac-hardware

    I seemingly followed all the steps, but I think I didn't install rEFInd correctly. In the installation process I had installed GRUB bootloader and since I have been unable to boot into OSX. I see the osx partition on Linux, but while powering up the computer and using the option key to choose an OS to boot into while clicking the macintosh hdd icon I get sent to a blank gray page with a cross and a circle around it.

    I've tried internet recovery, but it doesnt find any disks to install the new OS on.

    What should I do?
     
  2. lowendlinux Contributor

    lowendlinux

    Joined:
    Sep 24, 2014
    Location:
    North Country (way upstate NY)
    #2
    You're going to have to reinstall...

    Kali is not intended to be used like a day to day* OS it has one specific purpose and should only be run as a live environment. Secondly if you can't install it correctly you probably shouldn't even be using it. Everything available in the Kali is available in Debian/Arch/Ubuntu try using those and install what you need/want.

    *Yes you can install Kali, yes people like scriddies do, but that's not the intent and those people are the people that killed backtrack.
     
  3. john.carter32323 macrumors newbie

    Joined:
    Jun 30, 2015
    #3
    Hi krahmaja,

    You can boot into OS X with Linux using the help of below process:

    First, Boot your Mac into OS X. Then, install the rEFIt boot manager. It is very simple, simply download the disk image and double click on the installer. In order to confirm that this app is working, reboot your system. If you see some startup items, then it is good.

    Now, make some space to be available for Ubuntu installation. Once, you freed up some space, partition your drive.

    1. Open the Disk Utility (Application>Utilities>Disk Utility)

    2. Now, select the hard drive from the left hand side and click on the Partition tab on the right side.

    3. You will be able to see the current partition layout. After that, click on the right corner of the current partition and then shrink it to the size you want.

    4. After that, clicks apply. Disk Utility will shrink the current position for you and free up some space for Ubuntu installation.

    I hope, it will help you in fixing your problem.
     
  4. z31fanatic macrumors 6502a

    z31fanatic

    Joined:
    Mar 7, 2015
    Location:
    Mukilteo, WA USA
    #4
    His problem is that he can no longer boot in OS X. What you suggested won't help him.

    He needs to figure out how to install rEFInd on Linux. If the installation is successful, he should be able to see OS X in the rEFInd boot menu.
     
  5. v!talix macrumors newbie

    v!talix

    Joined:
    Nov 26, 2015
    #5
    Hi guys,
    I'm having a huge problem with rEFInd caused by me doing stupid things...
    I have Early 2009 MacBook A1181 without SuperDrive. With El Capitan installed I decided to get Linux working on that machine, so by following some instruction online I downloaded rEFInd and installed it. It didn't work well and I decided to reinstall it. I mounted EFI drive, found rEFInd folder and deleted its content (how stupid, hey), then I launched the installation of refind in terminal again. Although some warning massage appeared, after reboot the rEFInd interface appeared and it worked but there were some strange pictures insead of boot drives icons.
    I started OS and everything worked fine until I rebooted. After restart, grey screen appeared and nothing was happening (even no apple icon). I've tried cmd+R, opt+cmd+shift+power - nothing hepled. On my other laptop with ubuntu i've created bootable 16Gb USB drive from ISO image with OSX 10.6 and tried to boot from it by holding cmd+opt+shift+return, but it doesn't boot. I also held opt key and C - no result.
    Is there some other way to get it work or at least load into recovery interface or anything? Can someone help me with this, couse it seems I'm running out of options.
     

Share This Page