Unable to boot into single-user mode / "HD" partition dead?

Discussion in 'Mac Basics and Help' started by xantir, Sep 10, 2008.

  1. xantir macrumors newbie

    Joined:
    Sep 10, 2008
    #1
    My MacBook Pro (Mac OS X) refused to start, it hung up on the loading screen where you see the apple and the spinning loading wheel. I found out how to fix this, I had to go into single-user mode and type "/sbin/fsck -fy" to repair/verify the disk (I was unable to do so from the Disk Utility via the Install Disc, the repair/verify buttons were just grayed out).
    Anyways, doing this from the command line (single-user mode) fixed the problem and I could boot into Mac OS X (there were more issuses after this point which forced me to do an "Archive and Install").

    ^ that happened a week ago. And happened again yesterday, hung up on the exact same point. So I boot up my Mac into single-user mode, and type in "/sbin/fsck -fy" to start the process. Different from last time, I got a lot of text this time. It also kept going for a longer while. After about 10 minutes, there was a couple of minutes where nothing happened. So I typed "/sbin/fsck -fy" again (as I'm supposed to do so until it says "** The volume (name_of_volume) appears to be OK"), and I got some more text, then nothing happened for a while.

    Inpatient as I am, I considered the process to be complete, and restarted my Mac by typing "exit".
    I think I ****** up my Mac OS X partition at this point. Because when I try to start my Mac now, it automaticly boots into Windows XP (my other partition). Also I cannot enter single-user mode or Verbose mode, the Mac just ignores and goes right into Windows XP.

    I've tried to boot from the Install Disc. When I run Disk Utility, the "HD"(name of Mac OS X partition) is grayed out. I can't do an Archive and Install because it cannot detect my main partition.

    An interesting thing though: When I have the Install Disc inserted, I can enter single-user mode (by holding cmd+s at startup). However, when I type /sbin/fsck -fy, it starts verifying the Install Disc rather than the HD.

    Also when I open My Computer in Windows XP, I can see the other partition (MacDrive). When I select it, I see:
    Free Space: 219GB
    Total Size: 168GB

    This indicates that my HD is dead/erased, and that my last three months of work is gone. This just because I'm impatient, and didn't wait for the fsck process to complete.

    What is the next step? How can I get into single-user mode so that I can verify/repair my disc?

    I tried using DiskWarrior, but I can't boot via the DW-CD. I get to the point where I see the apple logo, then the Mac just restarts and tries to boot again. It restarts again on the same point, and this just continues.
    I've made sure I'm booting from the disc by holding options key while booting. I get two disks up: "Windows" which is my windows xp partition. and "DiskWarrior", the CD I have inserted, it has the DiskWarrior icon on it.

    I've tried both DiskWarrior 4.01 and 4.0 - same thing happens in both versions.
     
  2. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #2
    If your Data is worth something, you might need a tool like Data Rescue which recovers files from a troubled disk (accidentally deleted, corrupt HFS volume...) instead of trying to repair the volume.

    In this kind of situation, this is what I do:
    1) Try Single User mode, fsck -fy, and retry, if fail:
    2) Try Disk Warrior, if fail:
    3) Use Data Rescue II to recover the files, then repartition, or buy a new HD.
    Trust me, it has saved me many a time!

    It could be wise to start off with Data Rescue, TBH. You never know when you're doing more harm than good trying Disk Warrior on an already bad HD...

    Good luck.
     

Share This Page