Unable to change disk permissions on Read Only External Harddisk/time machine

Discussion in 'iMac' started by gloriole, Aug 7, 2010.

  1. gloriole macrumors newbie

    Aug 7, 2010
    I had reformatted my external harddrive a long time ago from the NTSC format to FAT32 for Mac and it's been working fine. I've been using it as my backup and time Machine. Today, I changed the disk permissions for my Mac HD to my user ID and set it as the owner to unlock some files and applied it to all folders within, I realized that my external harddisk is now a "read-only" and clicking on it reveals an error message: The folder "Capsule" could not be opened because you do not have sufficient access privileges.

    I tried changing the disk permissions from the Get Info section and was unable to change it. It states that I have Custom access on all my accounts but all efforts to try and change it to "read and write" has failed.

    I tried repairing it in Disk Utility but the options to do so are blanked out. Also, when I try running Disk Utility on my Mac HD I get the error message:
    First Aid Failed
    Disk Utility stopped verifying permissions on "Mac HD" because the following error was encountered:
    The underlying task reported failure on exit.

    I have very important information and data on my hard disk and I'm hoping someone could help me out on here.

Share This Page