Unable to Change Mac Address

Discussion in 'OS X Mavericks (10.9)' started by ButtonTeef, Nov 15, 2013.

  1. ButtonTeef, Nov 15, 2013
    Last edited: Nov 16, 2013

    ButtonTeef macrumors newbie

    Joined:
    Nov 15, 2013
    #1
    Hey everyone,

    So, I'm aware of how to change a Mac Address on an Apple computer using Terminal or applications like MacDaddy. I am currently running the latest version of OS X Mavericks (10.9) [Previously mistyped]

    For reference, here's an example of the Terminal commands I'm using:

    openssl rand -hex 6 | sed 's/\(..\)/\1:/g; s/.$//'
    (To generate a new, random Mac Address)

    sudo ifconfig en0 ether 69:b5:32:54:75:38
    (To change the Mac Address to the one at the end)

    ifconfig en0 |grep ether
    (To check that the Mac Address has been changed)


    So, no matter what I do, I cannot change my Mac Address on this MacBook Pro. It's a 2012 Retina.

    Any advice? I feel like my Mac Address may have been locked by some rouge IT guy.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Mavericks is 10.9. 10.8.5 is Mountain Lion.
     
  3. mrkramer macrumors 603

    mrkramer

    Joined:
    Jul 11, 2006
    Location:
    Somewhere
    #3
    I'm pretty sure MAC addresses are something that isn't supposed to be able to be changed, and is tied to the hardware.
     
  4. ButtonTeef, Nov 15, 2013
    Last edited: Nov 16, 2013

    ButtonTeef thread starter macrumors newbie

    Joined:
    Nov 15, 2013
    #4
    Mac Addresses on the airport cards themselves can be changed (spoofing). You can change your router's Mac Address also if you ever need to.

    I've been able to countless times before. But, now, it appears locked.
     
  5. mfram macrumors 65816

    Joined:
    Jan 23, 2010
    Location:
    San Diego, CA USA
    #5
    You may be able to change the MAC address, but the address you chose is a poor one. The least 2 significant bits of the top octet have special meaning and should always be zero for any legal MAC address. The address you chose does not follow that convention.

    Before deciding you can't change the MAC address, first choose one that conforms better to the standard.
     
  6. ButtonTeef, Nov 15, 2013
    Last edited: Nov 16, 2013

    ButtonTeef thread starter macrumors newbie

    Joined:
    Nov 15, 2013
    #6
    Not sure which parts you're referring to needing to be 0. I've tried about 30 combinations using both the randomizer command for Terminal (see above) and MacDaddy.

    Examples:

    C6:39:1D:1D:1E:70
    3D:9F:A0:9F:55:AD
    6F:B0:27:9F:55:AD


    The one you saw in the first entry (69:b5:32:54:75:38) was one that I had long ago. I just saved it for reference. That one worked fine at the time and, up until this week, I was able to successfully change my Mac Address and have it be perfectly functional every time. No internet or connectivity issues. All prior attempts worked fine. (The current Mac Address it's stuck on, different from 69:b5:32:54:75:38, hasn't affected my Internet at home.) I've probably done it about 50 times over the past few years.

    Any other suggestions?
     
  7. laurihoefs, Nov 16, 2013
    Last edited: Nov 16, 2013

    laurihoefs macrumors 6502a

    laurihoefs

    Joined:
    Mar 1, 2013
    #7
    Yes and no. Network devices become preconfigured with a hard coded MAC address, which is randomly generated within a certain range (parts of the address space are vendor specific), but there is nothing stopping the user from spoofing the address.

    If the OP is changing the MAC address of an AirPort card this does not really matter. The network interface is most likely going to be used in a local network only, behind a router. Setting the 'locally administered bit' would be the only convention that the OP might want to follow, but that is not absolutely necessary, and most vendors don't follow that convention with their NICs either. Even using an address from a vendor reserved address space is not an issue, and an address conflict would be very unlikely. The OP is not a hardware vendor with an assigned address block, but an individual user, so there are no 'legal' or 'illegal' addresses, as long as they don't cause conflicts.

    The situation would be different, if the OP was configuring a device facing WAN.





    Sorry OP, can't help you with your original issue...
     
  8. ButtonTeef thread starter macrumors newbie

    Joined:
    Nov 15, 2013
    #8
    That's fine. Good info though.


    This is the message I'm getting in Terminal:

    ifconfig: ioctl (SIOCAIFADDR): Device power is off


    I think this means that Terminal isn't able to spoof the Mac Address because it thinks the Airport card is off. But, that isn't the case.
     
  9. dek100 macrumors newbie

    Joined:
    Nov 28, 2013
    #9
    Hi,

    I found out that MAC spoofing works only for "good" MAC address, i.e. the ones which have as a second nibble 2, 6, A or E (as mfram suggested).

    Anyway c6:39:1d:1d:1e:70 should work...it worked for me( OS X 10.9, macbook air)

    Cheers
     
  10. chris.k macrumors member

    Joined:
    May 22, 2013
    Location:
    YSSY
    #10
    Correct

    The first byte of a host MAC address must be even. (First byte must end in 0, 2, 4, a, c, e) etc.

    An "odd" first byte is (generally) reserved for special addresses, such as the broadcast (ff) or multicast (01). Other link layer protocols use similar constructs.

    Most switches simply look at this first byte to indicate if this frame is unicast (even), or if it needs to be flooded (odd) to all member ports in the LAN (mcast, bdcast, etc....). Hence, That first byte is rather important. Setting a host mac by hand to an odd number may result in unpredictable or unintented consequences.
     
  11. JinLong macrumors newbie

    Joined:
    Sep 28, 2010
    #11
    I did this procedure and then checked it using the command "ifconfig en0 |grep ether" which show the new mac address i chose. So it seems all good but i went to System preferences > Network > Advanced.. and it's still show the real mac address!! is that normal?
     
  12. JinLong macrumors newbie

    Joined:
    Sep 28, 2010
    #12
    Nobody can tell me if it's still normal to see the real mac address into the System preferences > Network > Advanced.. after i successfully changed it in the terminal
     
  13. technotides macrumors newbie

    Joined:
    Jul 1, 2014
    #13
    same problem with me ...

    is its okay...
     
  14. tbone7467 macrumors regular

    Joined:
    Oct 5, 2007
    #14
    I've changed mine an terminal shows new address but network preferences shows old. It works just fine.
     

Share This Page