"unable to check for update"

Discussion in 'iPhone' started by Saintlycow, Mar 8, 2012.

  1. Saintlycow macrumors newbie

    Joined:
    Sep 29, 2011
    #1
    I own a iPhone 4s and an ipad2 and while trying to update ota it will check for an update for 30 seconds and then tell me "unable to check for update, an error has occurred while checking for a software update". This happening to anyone else?
     
  2. MacFan1701 macrumors member

    Joined:
    Mar 19, 2008
    #2
    I've been having this ever since the update was available......supposedly it's from the servers being clogged, but now, more than 24 hours later, I'm starting to wonder........
     
  3. Ecoh macrumors 6502a

    Ecoh

    Joined:
    Oct 30, 2009
    Location:
    USA
    #3
    Had this problem also, but just now the update has started to download.
     
  4. MacFan1701 macrumors member

    Joined:
    Mar 19, 2008
  5. Saintlycow thread starter macrumors newbie

    Joined:
    Sep 29, 2011
    #5
    DAY 3: still not letting me get into the download page
     
  6. Silofolous macrumors member

    Joined:
    Aug 12, 2009
    #6
    My ipad1 is also having this issue, very frustrating.

    Potentially useful tip: change your Dns to 8.8.8.8, or 8.8.8.6, or 208.67.222.222, or 208.67.220.220

    It didn't work for me sadly, but I've heard quite a few people saying it solved their problem. It's worth a shot at least.
     
  7. MacFan1701 macrumors member

    Joined:
    Mar 19, 2008
    #7
    Another day of this not working :/

    Is anyone else having this issue?
     
  8. andyx3x macrumors 65816

    Joined:
    Mar 1, 2011
  9. MacFan1701, Mar 9, 2012
    Last edited: Mar 9, 2012

    MacFan1701 macrumors member

    Joined:
    Mar 19, 2008
    #9
    This is true, but it's just bugging me that the OTA update isn't working and was curious as to why and if I was the only one.

    Plus, regardless of whether or not I can update through iTunes, I SHOULD be able to use the OTA updates should I so choose.

    Not trying to argue or anything, just stating facts that what should be working isn't.
     
  10. lordofthereef macrumors G5

    lordofthereef

    Joined:
    Nov 29, 2011
    Location:
    Boston, MA
    #10
    Android get's OTA updates, but the situation is the same. Some people have instant success while others wait hours or days. I am sure OTA will eventually work for you. How soon, is another question. When considering how many of these devices are likely trying to pull an OTA update, it is not shocking to me that it's still not working for some people, even three days later. I agree, it should work, but realistically it isn't going to for everyone right after the firmware launches. Even when I update through iTunes, I usually try and download the firmware from a third party site, that likely has less traffic.
     
  11. cozlarry macrumors newbie

    Joined:
    Sep 13, 2011
    #11
    Another that won't update!

    Just chiming in that my Iphone 4s has not been able to check for updates since the new IPad was released for pre-order. Coincidence?
     
  12. lordofthereef macrumors G5

    lordofthereef

    Joined:
    Nov 29, 2011
    Location:
    Boston, MA
    #12
    Yes, or at least I doubt it has to do with the iPad. I suspect it has more to do with people being aware that 5.1 is now available.
     
  13. cozlarry macrumors newbie

    Joined:
    Sep 13, 2011
    #13
    How to get the update!

    I have an IPhone 4s and could not get it to do the software update.
    Using information supplied by others, I successfully did the download and verfication!

    These are my steps:

    On the IPhone:
    1. Go to SETTINGS
    2. Go to Wifi
    3. Open your current Wifi screen (which should be checkmarked)
    4. Scroll down to the DNS
    5. Record the numbers so that you can replace them after the download
    6. Change the numbers to 8.8.8.8
    7. Exit out of SETTINGS by hitting RETURN on the screen keyboard
    8. HIT the HOME button
    9. Go back into SETTINGS
    10. Go into "General"
    11. Choose SOFTWARE UPDATE and you SHOULD GET THE UPDATE!
    12. After the update & verfication, the IPhone will reboot and finish installing
    13. Finally, remember to go back into SETTINGS - WIFI - and replace the DNS numbers you originally started with.

    I hope this helps someone else!

    -Larry
     
  14. MacFan1701 macrumors member

    Joined:
    Mar 19, 2008
    #14
    Saturday, it still wasn't working....I finally said screw it and did an iTunes update
     
  15. iSayuSay macrumors 68030

    iSayuSay

    Joined:
    Feb 6, 2011
    #15
    Well .. So much for calling iOS 5 unplug iPhone and iPad from computer, right?

    I had the same problem, days of waiting but still got the same error message. So in the end I just download the fill sized ipsw on my iPhone (using a download manager app of course), export it to computer and do the update the old way via iTunes. Problem solved!! :eek:

    If they really serious about unplugging iOS from computer, and OTA updates is messing up, at least Apple should allow us to use full sized ipsw file directly on iPhone/iPad. Just open the file anywhere from file manager app, and our device will recognize it and do the whole installation process. Without computer.
     
  16. Straytok macrumors newbie

    Joined:
    Sep 22, 2012
    #16
    Thx

    It worked.
     

Share This Page