Unable to connect to home wifi following iPhone 3.1 upgrade

Discussion in 'iPhone Tips, Help and Troubleshooting' started by AppleVirgin, Sep 14, 2009.

  1. AppleVirgin macrumors newbie

    Joined:
    Jul 11, 2008
    Location:
    London, UK
    #1
    Purchased my iPhone 3GS a month ago. Brought it home, opened Safari, found my home network (BT broadband on HomeHub 2.0), entered password and away I went. No problems. Fast forward to last Friday evening where I updated my phone software to 3.1. Download and install went off without a hitch. Opened Safari and was asked to enter my wifi password but after entering the following message popped up 'Unable to join the network "BTHomeHub2-JPS4" ' I have tried and tried to connect, reset the network settings on the iPhone, rebooted the HomeHub (router) on a couple of occasions and all to no avail, getting the same message every time (and yes it is the correct password). Wifi is working fine for 2 notebooks and my partner's iPhone, so no problem there. Also able to connect to wifi hotspots when out and about with no issue.

    Can only think it is an issue related to the 3.1 upgrade, too much of a coincidence otherwise.

    Anyone else have a similar issue/able to offer any advice?

    Thanks in advance.
     
  2. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #2
    Did you restore from your back-up? It may be worth trying that if you didn't, when I did it brought my wifi settings across. I did not have to re-enter the wifi key.
     
  3. sahild macrumors newbie

    Joined:
    Jul 10, 2009
    #3
    Same issue

    A friend of mine has the same issue. she has been connecting to her wifi network (belkin) for the last month since she got her 3GS but then today she reset her network settings, and then after that when she enters her password, it gives the "unable to connect to network" error.

    Also should be noted that she had been using the wifi network after upgrading to 3.1 too. So this really seems like a 3.1 issue related to the reseting of network settings...?

    Anyone else with insight would be appreciated.

    We tried restoring from backup (to when she was able to connect) and still no luck. We also tried reseting the network settings a few times... still no luck :(
     
  4. AppleVirgin thread starter macrumors newbie

    Joined:
    Jul 11, 2008
    Location:
    London, UK
    #4
    This problem has somehow righted itself now. Not sure what it was. Happy all the same though.

    :D
     

Share This Page