Unable to connect to Internet with Win7, wireless or wifi, bootcamp 3.1

Discussion in 'Windows, Linux & Others on the Mac' started by shaner2000, May 12, 2010.

  1. shaner2000 macrumors member

    Joined:
    Apr 13, 2010
    #1
    Initially the problem was just wireless. Now it's ethernet & Wireless.

    I have spent hours searching the apple support forums, the internet, and macrumors, including mroogle, and have not found a solution.

    What follows is everything I have tried (with the exception of [d] & [g]). Any other ideas?

    [a]
    I had the same problem on my new 15" MBP when running Win 7. My solution was:

    1. Click the small network icon in the lower right corner
    2. Click "open networks and sharing"
    3. Click "manage wireless networks"
    4. Right-click on your network and select "properties" from the context-menu
    5. Check the "connect even if the network are not broadcasting SSID" box



    Go to the Control Panel and click Hardware and Sound, then Device Manager(top right). In the Device Manager window, click on Network Adapters to expand the list. Right click on the network device that is not recognized or not working and select Update driver software. Select Browse my computer for driver software. Then, select Let me pick from a list of devices from my computer. In the Manufacturer list, scroll down to Broadcom. A list of drivers will then appear under Network Adapter. Scroll down the list and select Broadcom 802.11n Network Adapter (Broadcom) and click Next. Ignore the warning and select Yes. The driver should then install correctly.

    [c]

    I managed to fix it, I am using windows home premium 64 bit. What I did was I right clicked the network adapter in the device manager and selected update driver software. I then selected browse my computer for driver software and then selected let me pick from a list of device drivers on my computer. It populated a list so I went down to Broadcom (not Broadcom corporation) and selected Broadcom 802.11n (Broadcom).

    [d]

    I then put in the DNS tab in the network pane:
    208.67.222.222
    208.67.220.220

    [e]
    Changed Encryption to WPA2-PSK and WPA-PSK in router setup.

    [f]

    Firstly, I kept all the settings on my router solid. Just leave them as they are. Boot into OSX and check the Network settings and make a note of your IP address and the router's IP address.

    Second, boot into Windows, then open up your wireless connection settings and navigate through to the properties where you can set the IP address.

    Third: Set the IP address to your routers IP address changing the last set of digits to a value between 5 and 255 (I have 8 devices so I set the last two digits to 10.) This will keep the IP static.
    Tab through the Mask settings to default those.
    Then set the default gateway to your router's IP address.

    Check that the Network Adapter's setting has IPv6 disabled (uncheck the box)

    Finally: Set the primary DNS server to 8.8.8.8 then the secondary to 8.8.4.4 and then reboot the router.

    That's what got my connection running.

    [g]

    if you have the same problem just uninstall the nvidia nforce 10/100/1000mbps ethernet drivers. then refresh the hardware manager. you will now see the ethernet port as unknown hardware. then install it again but choose the drivers manual and install them from your snow leopard dvd (bootcamp 3.0). it seems like something is wrong about the ethernet driver from bootcamp 3.1. finally it should work, at least my ethernet port now does...

    [h]
    I finally sorted it out. I had my router set at WPA2-PSK. I read on the macrumors.com forums about adjusting the authentication. I switched to WPA-PSK and WPA2-PSK and now I am up and running.
     
  2. shaner2000 thread starter macrumors member

    Joined:
    Apr 13, 2010
    #2
    You know....I rebotted the router like 5 times tonight, and it finally worked. I'm not sure what finally got my computer and the router to shake hands, but, I don't care...at least it works now.
     
  3. MarkCL macrumors newbie

    Joined:
    May 18, 2010
    Location:
    Calgary, AB, Canada
    #3
    Bootcamp 3.1 Internet connection problem

    I just updated to 3.1 and immediately lost my internet connection (wireless only) on my Intel iMac. I too tried a bunch of things but since this is my work configuration I needed a fast fix. I rolled the broadcom driver back and that immediately fixed the issue.

    I'll investigate some of the things you've tried when I have time....: confused:
     

Share This Page