Unable to connect to McDonald's wifi and how to set router selection priority

Discussion in 'Mac Basics and Help' started by hajime, Nov 1, 2016.

  1. hajime macrumors 68030

    Joined:
    Jul 23, 2007
    #1
    Hello, I took my MBP 2010 17" to McDonald's yesterday. I was able to connect to their wifi in the past but not yesterday. I tried to connect my iPhone 6s plus to their network but also failed. However, the girl next to me was able to use their internet using a newer computer. What happened? If my MBP is too old, then I should be able to connect to their wifi using my 6s plus. However, it failed as well.

    The McDonald's is just across a school building. In the past, I could connect to the school's wifi router from McDonald's. However, my Mac always connected to the McDonald's wifi router first. Is there a way to set the preference so that when the school's wifi is detected, my Mac would connect to it but I want to connect to the McDonald's network (sometimes the school's wifi signal is weak as it is across the street), I could do it as well.
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    With regards to this:

    1) Click the Wi-Fi Icon at the top bar
    2) Select 'Open Network Preferences'
    3) Click 'Advanced' near the bottom-right
    4) Here you'll see your preferred networks. Simply click and drag the relevant networks in the 'order' you want them. Networks nearer the top will connect first, so dragging your school's Wi-Fi above MCD's will ensure it connects to the school first.
     
  3. hajime thread starter macrumors 68030

    Joined:
    Jul 23, 2007

Share This Page