Unable to create @icloud.com Apple ID

Discussion in 'iOS 6' started by danmcq, Jul 26, 2012.

  1. danmcq macrumors newbie

    danmcq

    Joined:
    May 16, 2011
    #1
    Has anyone had success creating an @icloud.com Apple ID with iOS 6 beta 3? Every time I try, I get the following error:

    Perhaps I'm missing something.
     
  2. J.C macrumors 6502

    Joined:
    Nov 12, 2008
    #2
    As far as I know you don't have to create anything. You already have it as an email alias. Have you tried emailing your normal ID with @icloud.com ? I tried after I read about the change and have received any emails since then sent to @icloud.com
     
  3. docmagoo2 macrumors member

    Joined:
    Dec 28, 2010
    #3
    I still can't seem to get my @icloud.com to work yet. Tried replacing @me.com with @icloud.com and consistently get delivery failure. My Understanding was it took a few days to activate but it still hasn't. Running iOS 6beta3, but tbh I don't care as @me.com is much easier than @icloud.com!
     
  4. monksealpup macrumors regular

    Joined:
    Jun 12, 2009
    Location:
    Honolulu, HI, USA
    #4
    Try logging in to beta.icloud.com. Then wait a bit (takes like 10 minutes?).
     
  5. docmagoo2 macrumors member

    Joined:
    Dec 28, 2010
    #5
    Did that. Working now, but took approx 2 weeks. I like the little pull down address selector
     
  6. diverbelow, Aug 2, 2012
    Last edited: Aug 2, 2012

    diverbelow macrumors newbie

    Joined:
    Aug 2, 2012
    #6
    Hey guys,

    Same issue on the IOS6 Beta 3, i am trying to register a new @icloud email ID but impossible from the add account on the mail section.

    Everything goes smoothy when filling up the info, but at the end it just says :

    Cannot create new apple ID, server Error.

    Do you know how can i proceed? Anyworkaround or reasons?

    If it works for somebody, I will be thousand grateful if one can help create one email iCloud? I will give the name which is available. And I will give him 10 euro via paypal.
    :)

    Many thanks guys
    Emmanue
     
  7. weenabby macrumors newbie

    Joined:
    May 24, 2013
    #7


    I'am also experiencing that problem for a week now. I cant access any apple apps that need apple id. it just say: cannot connect to apple server! can anyone help me please. it really gives me a lot of inconvenience
     

Share This Page