Unable to delete file from desktop

Discussion in 'macOS' started by talk2pj, Oct 19, 2011.

  1. talk2pj macrumors newbie

    Joined:
    Oct 19, 2011
    Location:
    Brisbane, Australia
    #1
    Hi,

    I copied/pasted a large MS PowerPoint file (55 Mb) from a Finder window into a folder on my desktop. The file must not have copied properly, because its icon stayed blank; it didn't change to reflect the first slide. The filename is also greyed out.

    I retried the copy/paste, and the file copied fine. But I can't delete the first version. I get the error you can see in my first attached screenshot, about the file being used by another application.

    I tried rebooting, but it didn't change anything.

    I searched the forums, and found the info in my second attached screenshot, about using Terminal to learn what application is using it.

    The results of that are in my third attached screenshot. The only application that seems to be using it is Finder. So I tried closing everything and relaunching Finder, but that didn't change anything.

    I'm scared to hit "continue" and try deleting the file, because last week I did exactly that, and I lost three full days troubleshooting my Mac crashing (including $200 in IT help).

    In the end, because I suspected something was amiss with my hard drive anyway, I bought a new drive and reinstalled all my applications from scratch. I'm now running a very clean, new drive, so this issue has me stumped as to why it might be happening again.

    The only other things that may be relevant are that I'm running SugarSync and Dropbox. One IT guy told me that these can corrupt data.

    I checked, and I:
    - Have read/write permissions on the file.
    - It's not locked.
    - I've run Disk Utility to repair permissions (this didn't fix it).

    BTW, in case you need to know, I'm running OSX 10.6.8 on a MacBook Pro (mid-2010).

    Sorry for the long story, but I thought you'd like as much detail as possible to help you solve it!

    Many thanks in advance for your help,

    Paul
     

    Attached Files:

  2. Mattie Num Nums macrumors 68030

    Mattie Num Nums

    Joined:
    Mar 5, 2009
    Location:
    USA
    #2
    try opening terminal and doing:

    rm -R "file path"

    if that doesn't work what I would do is create a new user that has admin privs, move that file to the Users/Shared folder, and then attempt to delete it as the other user. if that fails then we'll go from there.
     
  3. talk2pj thread starter macrumors newbie

    Joined:
    Oct 19, 2011
    Location:
    Brisbane, Australia
    #3
    Done!

    Thanks Mattie. I was nervous about using Terminal, but did a bit of reading before using it.

    I took the conservative approach, and just used rm [filepath], and it worked.

    Very happy. I wish I'd known about Terminal a few weeks ago; could have saved me a lot of time and money.

    Thanks again,

    Paul
     

Share This Page