Unable to delete files after 10.11 install

Discussion in 'OS X El Capitan (10.11)' started by Obsidian6, Oct 3, 2015.

  1. Obsidian6 macrumors 6502a

    Obsidian6

    Joined:
    Apr 29, 2006
    Location:
    Laguna Niguel, CA
    #1
    Hi guys,

    I tried to search for a solution but I'm not finding one presently. One of the many little bugs I'm experiencing with El Capitan is that I can't delete files. When I try to move something to the trash I get error code -43 essentially telling me that the file is missing / corrupt. I'm not sure what to do at this point, plus the fact that repairing disk permissions is gone, I'm just at a loss. I'm sure I'm just missing something, and that it has to do with a permissions setting SOMEWHERE. I just have no idea where it is.

    My machine is a 2012 Macbook Pro 15" (non retina) (see attached screen shot for spec)

    Any ideas?
     

    Attached Files:

  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    you've rebooted? fixed the issue for me recently...
     
  3. Obsidian6 thread starter macrumors 6502a

    Obsidian6

    Joined:
    Apr 29, 2006
    Location:
    Laguna Niguel, CA
    #3
    I did earlier but I will try it again. I'm in the middle of transferring my Time Machine backup to a new (larger) drive at the moment and it's taking an eternity.

    That's always the first thing I try when something turns wonky. Reboot! Haha.
     
  4. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #4
    Which files? SIP will prevent you editing/deleting system files. If in your home folder then you possibly have a permissions issue depending on how you migrated and data to your user account maybe???
     
  5. Obsidian6 thread starter macrumors 6502a

    Obsidian6

    Joined:
    Apr 29, 2006
    Location:
    Laguna Niguel, CA
    #5
    It's literally ANY file. Even just junk from the internet. I save a lot of various images, take screenshots, etc. I can't delete anything at all.

    I'll look into the permissions of my home folder as well.
     
  6. Obsidian6 thread starter macrumors 6502a

    Obsidian6

    Joined:
    Apr 29, 2006
    Location:
    Laguna Niguel, CA
    #6
    As an update, I tried relaunching finder and rebooting, both of these actions temporarily resolve the issue but it comes right back after an indeterminable amount of time.

    And now I'm getting an error in Disk Utility regarding my secondary internal SSD. I'm totally regretting updating to El Capitan at this point. My machine is more unreliable now than it's ever been. Screen Shot 2015-10-04 at 8.28.03 PM.png
     
  7. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #7
    The symptoms of a drive going into read only match a hardware failure, likely the HDD cable, I've had it. Run DriveDX if you can and look for interface errors, the cable is a cheap and easy replace. Just a coincidence it happened with the install of EC. If you are having it on both drives (ie a drive that hasn't had EC installed on it, that further indicates it isn't an EC issue).
     
  8. Obsidian6 thread starter macrumors 6502a

    Obsidian6

    Joined:
    Apr 29, 2006
    Location:
    Laguna Niguel, CA
    #8
    But if I can read from / write to both of my drives is it in read-only?

    I'll look into DriveDX.

    Still can't figure out the inability to delete files. Rebooting solves it every time but only temporarily.
     
  9. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #9
    Inability to delete files is. Does DU give you the ability to repartition? Just check if it does or whether it is greyed out. Rebooting will fix it until errors tell the system to put the drive into read-only again...
     
  10. Obsidian6 thread starter macrumors 6502a

    Obsidian6

    Joined:
    Apr 29, 2006
    Location:
    Laguna Niguel, CA
    #10
    Yes Disk Utility will allow me to repartition both internal drives.

    I wonder why EC would be causing these issues? I never had any permissions problems like this on Yosemite. Also I downloaded DriveDX and the only thing I came across was that my firmware on my older SSD is out of date, but I presently am unable to update it. Everything else checked out as OK by the system.
     

Share This Page