Unable to delete folder on TimeCapsule: not sufficient privileges

Discussion in 'macOS' started by sandert, May 8, 2008.

  1. sandert macrumors newbie

    Joined:
    May 7, 2008
    #1
    Hi y'all,

    I can't figure this out, with all the help I could find in this and other forums.

    What I've done:
    I copied a bunch of folders from a user folder on an iMac G4 with Tiger installed to Time Capsule, as a backup before a clean install. After putting these back to the iMac I started to delete the files on Time Capsule. All was well, except for this folder called 'Messages' on my Time Capsule. I got this error message:
    "The operation cannot be completed because you do not have sufficient privileges for some of the items."
    Now and then (not always!) I see a 'lock' on the folder, sometimes flashing a few times. Unchecking it in Get Info doesn't do anyting - it will reappear again.

    Trying to diagnose the problem:
    With Get Info I have 'custom access', and '(unknown)', 'staff' and 'everyone' all have Read & Write priviliges. I can't find a way to change any of these within the Finder.

    In Terminal with 'ls -lkbaeO' I get the following:
    total 12
    drwxrwxrwx@ 4 sander staff - 264 7 mei 10:02 .
    drwxrwxrwx@ 4 sander staff - 264 7 mei 10:53 ..
    -rwxrwxrwx@ 1 sander staff hidden 6148 7 mei 22:31 .DS_Store
    drwxrwxrwx@ 2 sander staff - 264 7 mei 11:34 Messages


    In the past few hours I learned about ACLs and a '+' behind the permissions, but i still don't understand the '@'. When using 'chmod -a# 0 sander' the return is that no ACL is present.

    I'm completely lost at this point. I can't do anything with this folder :mad:

    Can any of you heroes help me? Thanks a million in advance!!
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    I suppose you could always use sudo to become the super-user and force-delete the offending folder with rm -rf.
     
  3. sandert thread starter macrumors newbie

    Joined:
    May 7, 2008
    #3
    Thanks for your reply! But nothing happens. I type 'sudo rm -rf Messages', I'm asked for my password, which is accepted, and return to the prompt without notice, but the folder is still there...
    Is this really a mystery? What could cause this? And how do I go from here, without re-format the drive?!
    Thanks for any further help...
    - Sander
     
  4. Shrewdude macrumors newbie

    Joined:
    Mar 16, 2008
    #4
    work around

    The following is a workaround that was posted on another forum by Goose that I used a few months ago:


    OK folks...here is a solution. At least this is working for me. I've deleted about half my bad folders so far.

    I stumbled across this post...

    http://forums.macrumors.com/showthread.php?t=454924

    I happened to have Tinkertools and FileBuddy installed on my system. I told Tinkertools to show hidden files. I then select a bad folder and tell FileBuddy to make that folder "invisible". I can see it however since TT has "shown invisible files". I then just hit the delete button and Poof! Its gone.

    I have no idea why this works but I thought you might want to relieve some of the pent up frustration :)

    One caveat. Filebuddy on my system is rather unstable. I can delete a folder or three and then Finder crashes and relaunches. I would guess there are many ways to make files invisible that might be more stable but this works and really doesn't seem to do any real harm.

    Tinkertools has another handy checkbox that stops finder from putting a crapload of invisible files on the TC or other network drive.... so your windows boxes don't see all that crap if you have set up to see all files.

    For what its worth....
     
  5. dylandmcleod macrumors newbie

    dylandmcleod

    Joined:
    Apr 5, 2008
    Location:
    New Zealand
  6. sandert thread starter macrumors newbie

    Joined:
    May 7, 2008
    #6
    Invisibility-thing worked!

    It worked! Thanks Shrewdude for your tip!
    Strange I didn't find the page myself when I searched for a solution...

    What I did: with Path Finder showing invisible files I got info on the folder and unlocked it. With Get Info still open I navigated to a 'higher' folder and deleted it (for some reason I couldn't delete the newly unlocked folder itself). And now it has finally gone!

    Thanks again.

    - sandert
     
  7. moroz1984 macrumors newbie

    Joined:
    Jun 24, 2012
    #7
    Hi, Also stumbled upon the same problem.
    But tried another solution with success:
    Right-click on the trouble folder -> Services (or whatever your translation is) -> Delete with CleanMyMac.
    CleanMyMac (2.0.7) launched the shredder and *puff* the folder was gone.
    Of course, CMM needed to be installed :D
     

Share This Page