Unable to delete .inProgress files from trash

Discussion in 'Mac Basics and Help' started by danes78, Jul 23, 2015.

  1. danes78 macrumors newbie

    Joined:
    Apr 2, 2011
    #1
    I have been stuck with this problem for months. There are 2 .inProgress files currently in my trash on my external hard drive that I used for back-ups with Time Machine. I stupidly deleted them when I received an error message about Time Machine being unable to complete a back-up and I instantly regretted my decision!
    I have tried the sudo rm -rf command lines with the files with no luck. Here is the garble I receive from terminal when I attempt to delete either file:

    danas-imac:~ dana$ sudo rm -rf /Volumes/Dana\'s\ back-up/.Trashes/501/2014-09-09-235304.inProgress
    Password:
    rm: /Volumes/Dana's back-up/.Trashes/501/2014-09-09-235304.inProgress/.Backup.432013984.876549.log: Invalid argument
    rm: /Volumes/Dana's back-up/.Trashes/501/2014-09-09-235304.inProgress/B855BBA7-18F4-406C-8B00-BB5FAD053BCF/.exclusions.plist: Invalid argument
    rm: /Volumes/Dana's back-up/.Trashes/501/2014-09-09-235304.inProgress/B855BBA7-18F4-406C-8B00-BB5FAD053BCF: Directory not empty
    rm: /Volumes/Dana's back-up/.Trashes/501/2014-09-09-235304.inProgress: Directory not empty


    I'm wondering if anyone can help with this! I can't erase the external drive, as the files are "in use" and the drive therefore, can't be unmounted. I can't reformat the drive for the same reason. I can't even eject the drive from the desktop, as the computer states the files are in use.

    Time Machine is off during all these attempts. I'm running an early 2009 iMac with Yosemite version 10.10.4.
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    If you just want to erase the external drive, and be done with it -
    Boot to your recovery system (restart holding Command-R)
    Open Disk Utility, then erase the hard drive.
     
  3. danes78 thread starter macrumors newbie

    Joined:
    Apr 2, 2011
    #3
    Thank you, thank you, thank you!! I had assumed that disk utility wouldn't work in recovery mode as it wouldn't work in regular mode. This has solved the issue!
     
  4. prisstratton macrumors 6502

    prisstratton

    Joined:
    Dec 20, 2011
    Location:
    Winnipeg
    #4

Share This Page