Unable to delete trash files

Discussion in 'Mac Basics and Help' started by hotrodsinner, Jan 18, 2008.

  1. hotrodsinner macrumors newbie

    Joined:
    Jan 18, 2008
    #1
    I've pretty much tried everything I can think of but I'm unable to empty 2 files my trash can I can drag the two files out and they just disappear but when I go back to the trash they are both back again. Any help would be greatly appreciated.
     
  2. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #2
    did you try using OnyX to force clear trash can?
     
  3. hotrodsinner thread starter macrumors newbie

    Joined:
    Jan 18, 2008
    #3
    Honestly I've never heard of it but I'll give it a go, Thanks
     
  4. hotrodsinner thread starter macrumors newbie

    Joined:
    Jan 18, 2008
    #4
    Nice program but it didn't do the trick, both the files seem to be corrupt which may be the issue. I've attached a screen shot of my trash window.

    http://idisk.mac.com/nath.mel-Public
     
  5. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #5
    With the possible corruption you can attempt to do a Repair Disk Permissions. You'll find this in the Disk Utility app. Select your hard drive from the left, then click the Verify Disk Permissions, and if it finds problems you can use the Repair Disk Permissions button.

    Something else to try, go to Terminal, type: cd .Trash then type ls -ago and copy and paste the results here. It may reveal something about the files that we can use to help.
     
  6. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #6
    Have you tried Finder > Secure Empty Trash?

    That has yet to fail me in Leopard and I've come across a few tough to delete file.
     
  7. redAPPLE macrumors 68030

    redAPPLE

    Joined:
    May 7, 2002
    Location:
    2 Much Infinite Loops
    #7
    can you move the files from the trash to let us say, the desktop?
     
  8. teleromeo macrumors 65816

    teleromeo

    Joined:
    Dec 2, 2006
    Location:
    kidnapped by aliens
  9. dansickle macrumors newbie

    Joined:
    Feb 29, 2008
    #10
    I have the same file with the little null symbols and the two umlauts, I looked at it in terminal. It turns out that it is a file in the trash of my windows partition. So if you're like me and have a windows partition just try booting that up and emptying the recycling bin. In theory that will solve it, I'm just too impatient to boot XP to see if it actually works.
     

Share This Page