iPhone Unable to download 1 specific iBook to iPhone

Discussion in 'iOS 8' started by MED1975, Jul 15, 2015.

  1. MED1975 macrumors newbie

    Sep 26, 2014
    Brighton, United Kingdom
    I preordered "Go Set a Watchman" and it has downloaded successfully on my iPad and Mac - but on my iPhone it wont.

    I suspect there is a corrupt download on my phone as all other iBooks will download to my phone.

    I have tried hiding and unhiding the book but it still will not budge. Basically pressing the download button does nothing except grey out the book and put the usual progress bar up. I have tried turning my phone off and on, quitting iBooks etc. All this does is return the book to the non-greyed out state.

    Will the iPhone automatically delete old temp downloads after a certain period of time? Can anyone suggest anything else I can try? I would rather not restore my phone for this, but equally want it to work - I read books on my phone at work!

    All suggestions gratefully received!
  2. paulbol macrumors newbie

    Dec 22, 2014
    I actually had that issue last night with ibooks. The book downloaded to my ipad but not my phone. I did the same things you did but I turned off wifi thinking that was the issue. After a few other unsuccessful attempts, I turned wifi back on giving up and noticed the book downloading.

Share This Page