Unable to download from App Store

Discussion in 'OS X Mountain Lion (10.8)' started by nuttyal, Jul 26, 2012.

  1. nuttyal macrumors newbie

    Joined:
    Jul 26, 2012
    #1
    Hi all,

    I have been trying to download Mountain Lion from App Store without success.

    I have the following message appear:

    "We could not complete your purchase.
    The product distribution file could not be verified. It may be damaged or was not signed."

    This also happens on my wife's Mac Book.

    I am using Virgin Media provider (30MB) through Virgin modem hub and Apple time capsule. Have tried disabling anti virus - no change. Have tried by-passing time capsule and direct into iMac - no change.

    Apple support are trying to resolve issue, but I thought I would ask on Forum if anyone had any ideas on how to solve issue. Apple say my iMac and Mac Book are both running correct OSX.
     
  2. Jeff Chen macrumors member

    Jeff Chen

    Joined:
    Jun 16, 2009
    #2
    Maybe there's something in your hosts file, like blocked VERSIGN servers.

    I fixed my game center connection problem by commenting out those lines.
     
  3. SRRM macrumors member

    Joined:
    Feb 18, 2011
    #3
    can u tell me how to did 4 game center?
     
  4. Jeff Chen macrumors member

    Jeff Chen

    Joined:
    Jun 16, 2009
    #4
    Find your hosts file at /private/etc/hosts, see if there is any line about VERSIGN, and put a # at the beginning of the line.

    This involves using terminal to modify your hosts file, so you might wanna look up how it's done.
     
  5. deimos72 macrumors newbie

    deimos72

    Joined:
    Feb 12, 2009
    #5
    It's that! THANKS!!! :)
     
  6. OhKay macrumors newbie

    Joined:
    Mar 7, 2010
    #6
    I'm getting same error. My host file only contains:

    127.0.0.1 localhost
    255.255.255.255 broadcasthost
    ::1 localhost
    fe80::1%lo0 localhost

    Repairing permissions on start-up drive didn't help. I have an otherwise up-to-date OS 10.7.4.
     
  7. Tasker macrumors newbie

    Joined:
    Sep 4, 2009
    #7
    Solution

    I had same error message, contacted Apple. They advised booting into safe mode then to try it.

    Worked a treat, just make sure all progs are shut down before rebooting into safe mode (shift key held down when first booting)

    Not sure if it's just a quirk for ML.


     
  8. OhKay, Jul 27, 2012
    Last edited: Jul 27, 2012

    OhKay macrumors newbie

    Joined:
    Mar 7, 2010
    #8
    After a safe boot I got the following message:

    [​IMG]

    Googled around looking to see if there was some sort of Mountain Lion compatibility issue. I'm hosed! I have an April 2007 Mac Pro. Mountain Lion only works on mid 2007 or later Mac Pros. Shazbot!!!

    Damn 5-year-old Mac that keeps working! If I had a PC I would have probably purchased two of them in the last 5 years and automatically got major system upgrades that way.

    NOTE: When going to About This Mac in the Apple menu, my machine is identified as a MacPro1,1. There is another thread in this forum dealing with installing ML on older machines but there are a lot of steps involved and some hardware upgrades may be necessary (e.g., a newer video card).
     
  9. nuttyal thread starter macrumors newbie

    Joined:
    Jul 26, 2012
    #9
    Was in contact with Apple Care technician Thursday afternoon (UK) about error message and not being able to download ML. He checked my Mac was compatible for ML - which was fine. Also checked my App Store account details - which were fine.

    He was unable to offer any assistance at that time and was going to look further at issue and call me back.

    He was to have called me back by sometime yesterday evening (Friday) - I'm still waiting and very disappointed.

    One fact that I did discover during our diagnosis session, is that this issue is also related to other major Apple applications purchased from App Store - e.g. Pages, Keynote and Numbers. Other non-Apple related applications are not affected.

    Looks like my issue is definitely Apple related.

    I wait with baited breath for response from Apple Care!!
     
  10. nuttyal thread starter macrumors newbie

    Joined:
    Jul 26, 2012
    #10
    :D

    Latest update!

    Following suggestion from Tasker to boot into safe mode, I have now successfully downloaded ML.

    Many thanks Tasker.

    Must admit I didn't think of doing this myself!

    I would have thought that Apple Care tech would have suggested this!!

    Now a Happy Bunny!

    Task now is to find any bugs.....Ugh!

    :D:D:D
     

Share This Page