Unable to download item. Please try again later.

Discussion in 'iOS 8' started by robmadden1, Sep 18, 2014.

  1. robmadden1, Sep 18, 2014
    Last edited: Sep 19, 2014

    robmadden1 macrumors member

    Joined:
    Jun 3, 2014
    #1
    After updating to iOS8, whenever i turn off and power my ipod touch 5g, I receive a pop-up "Unable to download item. Please try again later. " At first I thought it was an app or the U2 download that has goe bad but in the appstore I did not see anything suspicious. After resetting and restoring my device the pop-up kept appearing. By mistake I discovered that if I open the iBooks app the pop-up appears every time.

    Is this happening to anyone else besides these 2 people: https://discussions.apple.com/thread/6540292
     
  2. robmadden1 thread starter macrumors member

    Joined:
    Jun 3, 2014
    #2
    Its a bug with entering your apple id during the setup of ios. I was on with tech support and we figured out the issue by storing my ipod and not logging in to my apple ID during te setup and the popup has yet to return so we both think its a bug with the setup of the apple id during the setup of ios8.
     
  3. nikusak macrumors member

    Joined:
    Feb 11, 2014
    #3
    I was just about to start a new thread about this, but found this.

    So yes, I am getting this too on my iPad Air. Extremely annoying! It is somehow related to iBooks. I had the same problem on my iPad 2 at some point, probably after upgrading to iOS 7. I don't remember what I did to get rid of it.

    I have not done a full reset or anything like that. Just re-downloaded all the books I have ever gotten from the store. It didn't help. Just got the pop-up while watching Vimeo in Safari :-(

    (I think these kind of warnings should not be pop-ups, but rather appear like banners or badges if the user is not in the app which generates it. Although in this case the culprit is some system background process, but perhaps even more so: NO pop-ups EVER unless generated by the foreground app! This happens sometimes with AppStore too with my flaky wifi, I get an annoying pop-up about failed download, allowing me to cancel or retry.

    Hey Apple, I don't care! Just retry AUTOMATICALLY for a few times because it nearly always works with one retry! If it still fails, then just mark the app as un-updated so that I can try later. STOP bothering me with pop-ups!)

    In Apple discussions somebody mentions the option about allowing books to update their content via Internet. I think I might have that disabled...

    (I can't check now so that I don't get a tab reload in Safari :-0)

    ----------

    No, everything was enabled, syncing and online access in iBooks settings.

    Well, now I disabled all of of those.

    If that doesn't help, I guess I have to do a full reset then :-(
     
  4. nikusak macrumors member

    Joined:
    Feb 11, 2014
    #4
    I think nearly everybody would be having this problem if just signing in during setup after OS upgrade was causing this. Of course it's possible that you are right, but for some reason this only affects very few users.

    Anyway - so you erased everything, restored everything from backup, skipped Apple ID sign during setup, and then logged in with Apple ID later?

    I guess I will have to try that too. I just got the pop-up again. Earlier I got it the exact moment I came back here to check this thread :-0
     
  5. MED1975 macrumors newbie

    Joined:
    Sep 26, 2014
    Location:
    Brighton, United Kingdom
    #5
    Having the exact same issue too, but only on my iPhone 5S. My iPad is fine and not getting the problem. Both on 8.0.2. My suspicion is that it is connected to having upgraded to iCloud Drive - have you all done this too?

    My guess is that it is actually trying to download missing keyboard shortcuts which also haven't worked since iOS 8 - missing on my phone but present on Mac and iPad. For what its worth I have also set my my phone as a brand new phone, and it didn't go away!
     
  6. Travisimo, Sep 26, 2014
    Last edited: Sep 26, 2014

    Travisimo macrumors 6502a

    Joined:
    Dec 22, 2009
    #6
    I am having this problem on my iPhone 6 Plus. It continues to happen even after the iOS 8.0.2 update, so that didn't fix it.

    I cannot seem to identify a pattern for when it shows up. For me, it doesn't pop up when I open iBooks, so I don't know if it's related or not. It just pops up randomly when I am using my phone... in apps, in safari, on the home screen, it doesn't seem to matter what I'm doing. Sometimes it will not pop up for hours, but sometimes it will pop up 2 or 3 times in a row over a period of a couple of minutes.

    I have tried most of the troubleshooting tips mentioned in the Apple Forums thread. I removed the U2 album from my account, but I don't think that was ever a problem because it never showed up on my phone anyway (I don't have automatic music downloads set up).

    If the pop up would just specify what it was trying to download, it would make troubleshooting a LOT easier. For me, it shows up every time I reboot a few seconds after the home screen appears. But it doesn't show up when I open iBooks. It doesn't seem to matter if I click "Done" or "Retry" - it will eventually show back up anyway.

    I have been trying to think about this:

    - It's something that has background privileges
    - It's something that tries to execute when the phone first boots for sure
    - It's something that is trying to download but cannot complete
    - It's something that shows up on various iOS devices (iPhone, iPad, iTouch)
    - It's something that has popped up with iOS 8 (though it has happened before, this particular one seems to be unique to iOS 8)
    - I thought maybe it was related to iTunes Match, so I disabled that on my phone but the popup persists.
    - I initially set up my phone as new, so it's not a carry over from a restore

    If I remember correctly, it started happening after I made a music album purchase from my phone. During the album download, there was an error message about downloading but it was not the popup we're seeing now. And it went away with the album successfully downloaded. I have also deleted all of the music off of my phone to make sure that wasn't the problem.

    Also, I did do the iCloud Drive upgrade, so I don't know if all of us who are experiencing this have upgraded to iCloud Drive?

    It's very annoying to be sure. I sure hope we find a solution soon.

    EDIT: I turned off iCloud Drive on my phone, then rebooted. The popup still appeared a couple of seconds after booting. I don't think this necessarily discounts iCloud Drive as the culprit, but it's perhaps less likely so. The popup DOES appear EVERY single time I reboot the phone, within 2-3 seconds after the home screen appears.
     
  7. MED1975 macrumors newbie

    Joined:
    Sep 26, 2014
    Location:
    Brighton, United Kingdom
    #7
    Okay - can everyone chime in.

    Do you run Yosemite?
    Have you upgraded to iCloud Drive?
    Did you download U2?

    My answer is yes to all three...and I hate U2
     
  8. Travisimo, Sep 26, 2014
    Last edited: Sep 26, 2014

    Travisimo macrumors 6502a

    Joined:
    Dec 22, 2009
    #8
    I'm getting the message every time I boot and periodically while I am using the phone. And....

    1) Not running Yosemite.
    2) Yes, upgraded to iCloud Drive, but also disabled this on my phone and rebooted with the same message.
    3) Did NOT download U2, but did remove it from my account just to make sure. Do not see any pending downloads on the phone or in iTunes.

    I did download two music albums (not US) since getting my iPhone 6 Plus and there was a download error with one of them, but it did finish downloading and nothing seems to be stuck. I also tried deleting all music off of my phone and turning off iTunes Match. Nothing helped.

    EDIT: I had never opened iBooks on my new phone before seeing this message, so if it IS related to iBooks, then it's not because of opening the app. Furthermore, I ironically do NOT get the message popup when opening iBooks now at all.. never. But I repeatably get the message EVERY time I reboot the phone (within 2-3 seconds after the home screen appears).
     
  9. hummus macrumors member

    Joined:
    Nov 28, 2012
    #9
    I don't run Yosemite.
    I haven't upgraded to iCloud Drive.
    I didn't download U2, at least not on purpose.

    I did however use iBooks for the first time in a long time right around the time that this started happening to me, so I think the person that mentioned that might have been on to something. Just now out of curiosity after reading the post mentioning iBooks I opened iBooks and immediately got the message again.
     
  10. MED1975 macrumors newbie

    Joined:
    Sep 26, 2014
    Location:
    Brighton, United Kingdom
    #10
    its now stopped happening for me - anyone else fixed?
     
  11. eelw macrumors 6502a

    eelw

    Joined:
    Sep 19, 2012
    #11
    No/no/yes but removed it after

    And I only get the message when to restart the phone.
     
  12. Travisimo macrumors 6502a

    Joined:
    Dec 22, 2009
    #12
    Still happening here, the same. Happens every time I reboot for sure. And happens occasionally while I am using the phone. Still can't figure out why.

    I am running the latest version: iOS 8.0.2 with my iPhone 6 Plus.
     
  13. Jstuts5797 macrumors 6502a

    Joined:
    Dec 15, 2013
    #13
    I'm having this issue on my iPad Air but not my 5s. Both have 8.0.2 I never setup iCloud Drive, I do have the U2 album and never attempted to delete it. I have no Mac to run Yosemite. It happens after boot up and randomly throughout the day. It seems downloading anything from the App Store triggers it too. If anyone find the answer let me know!
     
  14. CKohkah macrumors 6502

    Joined:
    Jan 10, 2008
    #14
    For what its worth, I installed 8.1 beta 1 on my iPad air last night and this error is now gone. So at the very least this issue should be cured when they release 8.1 to the public sometime in October.
     
  15. Travisimo macrumors 6502a

    Joined:
    Dec 22, 2009
    #15
    That's great! Thanks for the update. Now then, did iOS 8.1 beta introduce any new bugs of its own? :cool:

    As for me, the popup persists on my iPhone 6 Plus running 8.0.2 and I have basically accepted the fact that it's not going away on its own. I have tried basically every trouble-shooting method suggested shy of starting over as new. It comes up every time I reboot without exception, and at least a few times throughout the day (usually when I'm doing something that requires the network, whether it's the App Store, iTunes, Mail, etc). No pattern that I can discover.

    If it's gone in the next update, I'll be happy. If it persists, I'll have no choice but to start over as new.
     
  16. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #16
    Just installed iOS 8.1 beta on my iPhone 5 and after the install finished and the phone booted up I still got the alert after a few minutes. Restarted the phone, just to check on it again, and unfortunately got the alert after a few minutes once again. (In fact, getting the alert twice almost in a row it seems.)
     
  17. arbogast777 macrumors regular

    Joined:
    Sep 4, 2010
    #17
    I get it on my Air but not my 5S. got to be the most annoying bug I have ever encountered.
     
  18. Travisimo macrumors 6502a

    Joined:
    Dec 22, 2009
    #18
    That's very disappointing. I haven't tried the beta, but I'm getting to the point where I might just have to erase the phone and start over as new. I was going to wait until 8.1 since there was hope that would fix it.

    I can consistently and repeatedly get the error just by rebooting my iPhone 6 Plus (it ALWAYS appears within 5 seconds of rebooting). Today, though, it has appeared no less than a dozen times throughout the day. One time it even popped up while I was recording a video! It had to have popped up about 6 times in less than an hour's time. Then it didn't appear again for several hours. I cannot for the life of my discern any kind of pattern, other than forcing it to appear by rebooting.

    If the message would just state what it's trying to download, it would go a long way in troubleshooting it. But without any kind of reference at all, we don't even know if it's the same thing on every device that's experiencing it. For some people, it could very well be that darned U2 album, but I don't think so on my phone. My phone never had the album, never tried to download the album, and I removed the album from my iTunes account using the link from Apple. I even downloaded it on purpose to my computer and phone thinking maybe it just needed to finish something. But none of that helped. The only possible lead I have is that I did purchase two albums on my phone a few days ago (I think before the error occurred). During the album download, there was an error (not this one, but something else) that went away and the albums seemed to download properly. I deleting them and retried but that didn't fix anything.

    I'm not sure I even understand how these digital booklets with albums are supposed to work? They download on the computer in iTunes, right? But they don't download to the phone unless you purposefully sync them via iTunes? Not sure if there's something I can do to see if a digital booklet is stuck? I don't see any digital booklets in iBooks on my phone, and I even tried turning iBooks sync off.

    Also, is there a way for us to report this to Apple without being a developer?
     
  19. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #19
    You can do it as a free developer (which anyone can be) at http://bugreport.apple.com
     
  20. Travisimo macrumors 6502a

    Joined:
    Dec 22, 2009
    #20
    UPDATE:

    I figured I had nothing to lose by trying to backup, erase all, and restore via iTunes, so I did just that and now the popup seems to have gone away. I have rebooted my phone twice now after the restore completed and it hasn't come back. And while I'm glad it's gone for now, I'm afraid that not knowing the cause of it will mean it will end up coming back to haunt me!
     
  21. Travisimo macrumors 6502a

    Joined:
    Dec 22, 2009
    #21
    UPDATE #2:

    So as I described in my prior post, I was able to fix this issue by backing up my iPhone to iTunes, then erasing the phone, then restoring from backup in iTunes. This completely eliminated the popup and I have been using my phone since then without issue.

    However, I am now able to duplicate the problem, and it's definitely an issue with music downloads on the phone. I do think it's specifically the Digital Booklets that are part of album purchases. That's why for some people it was the U2 album that automatically downloaded. For me, that was NOT the problem because the U2 album never downloaded to me device, nor did I try to download it (I had auto downloads disabled).

    For me, it was the purchase of an entirely different album that caused the problem (but an album that still had a digital booklet). I didn't know that was the problem until I tried to purchase another album after doing the erase/restore on my iPhone.

    So I purchased an album from iTunes on the phone and everything seemed to download fine (all of the songs and music videos downloaded fine). But guess what popped up at the end of the album download? Yep, the "Unable to download item" message. And now, it's doing the same thing where it appears EVERY time I do a reboot of the phone, and pops up occasionally while using the phone too.

    And again, I have tried everything to fix the problem without success. Since I knew exactly which Digital Booklet was causing the problem, I thought maybe I could fix it. I plugged in my phone to my Mac and attempted to do all sorts of syncing with Music on/off, Books, on/off, etc. If I try to open the Digital Booklet for this album on my Mac, it will not open (says it's corrupted, even if I redownload it from the cloud). Not sure if that is part of the problem or not.

    At any rate, I am now doing another erase and restore and will NOT be doing any kind of music downloads on the phone until this problem is fixed. It's definitely an issue with cloud downloads of music albums. I could probably have avoided the problem by just downloading the songs individually instead of touching the Cloud icon for the entire album. I would think that downloading individual songs would be okay, but I don't want to be the guinea pig again! LOL.

    Can anyone else verify this? If you're brave enough to try it out, just download an album you've already purchased by going to iTunes on the phone/iPad, click the Cloud icon next to the entire album (not the songs themselves). Wait for your entire album to finish downloading, and then see if you get the error. If not, reboot and see if it appears then. Make sure it is an album that has a DIGITAL BOOKLET with it.
     
  22. Jstuts5797 macrumors 6502a

    Joined:
    Dec 15, 2013
    #22
    Anyone ever able to fix this issue? It's still happening on my iPad and I've updated to 8.1
     
  23. nikusak macrumors member

    Joined:
    Feb 11, 2014
    #23
    Yes...unless you mean "fix without doing a full reset".

    I tried everything I could think of, I even converted and then synced the U2 digital booklet (which I think is connected to this problem, but I am not sure) into my iPad using iTunes. It didn't help.

    So, I gave up, backed up my iPad, did "Erase all content and settings", selected "Restore from backup" during setup (instead of "setup this iPad as new") and I haven't seen the dialog since that.

    I upgraded to iOS 8.1 first if I recall.
     
  24. Veevivrett macrumors newbie

    Joined:
    Jan 12, 2015
    #24
    This is still happening. Driving me crazy. I actually had it stop for a bit yesterday. Almost definitely related to iBooks and digital booklets. Anyone know anything more?
     
  25. Fraserpatty macrumors newbie

    Joined:
    Mar 5, 2015
    #25
    Has anyone been able to fix this without a restore?

    I hope for a bug fix with each update, and so far it's still here. Very annoying.
     

Share This Page