Unable to edit/view/share project IMOVIE

Discussion in 'Mac Apps and Mac App Store' started by acm417, Jun 2, 2010.

  1. acm417 macrumors newbie

    Joined:
    Jun 2, 2010
    #1
    I have been working on a project in iMovie for a few days, and it has been working perfectly. Today, I opened up my project and I could not play the project (the red line would move, but no picture would show up in the upper right hand corner box) and ALL of the options in the "share" tab were gray and unable to click them. Many options in the "edit" and "file" tabs were unable to be clicked as well.

    Any advice? I've tried restarting the computer and researching possible solutions online, but I have yet to find anything. Please let me know if anyone has any ideas!

    Another project i completed months ago is working perfectly.
    The clips in the events play/show up on the window in the upper right hand corner
     
  2. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #2
    Have you tried repairing Disk Permissions? Utilities>> Disk Utility First Aid tab, select the drive where your project is stored, and repair permissions.
     
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
    Hate to tell you this but I think that the project was damaged somehow. Your best and honestly only bet is that the project was backed up with Time Machine and you can recover it through there. First make sure you're quit out of iMovie, then in Finder, go to ~/Movies/iMovie Projects and locate the project you can't play back or make edits to. Then launch Time Machine, navigate to a previous date/hour and try restoring that project file.

    @bmcgonag: No amount of repairing disk permissions is going to fix a project-specific issue in iMovie, and honestly that suggestion is a bit overused on these boards. This Apple support article goes more in-depth about what the repair disk permissions feature actually does. It may be something to consider running if all applications are going haywire, but the OP would have mentioned that as a symptom.
     

Share This Page