Unable to eject iPod Nano

Discussion in 'Digital Audio' started by Teugeus, Feb 22, 2016.

  1. Teugeus macrumors member

    Joined:
    Oct 7, 2013
    #1
    I've been using an iPod nano for many years now to listen to music, particularly when I go jogging. There seems to be a bug when syncing with a Windows 7 computer whereby a message appears that the iPod cannot be disconnected after trying to eject it because it's still in use even though disk mode is disabled and it has finished syncing.

    Anyone else experienced this particular issue ? The strange thing is, once the sync is complete I can simply unplug the iPod and everything works fine, all the music I selected to sync has been safely added to the iPod's library.
     
  2. Simche macrumors member

    Simche

    Joined:
    Jul 27, 2015
    Location:
    Europe
    #2
    Hmm try the following stuff if you haven't already:

    1) Install latest iTunes, remove all cables from every USB-port and restart. Try again

    2) Swap between USB-ports, sometimes it makes a difference in Windows

    3) Uninstall iTunes, remove all objects from USB, Restart. Re-install iTunes, try a USB-port and sync then try to eject.

    When I was a Windows user, one of these stuff helped me and it worked in random (so one of this 3 options worked but never same for every incident)
     
  3. Teugeus thread starter macrumors member

    Joined:
    Oct 7, 2013
    #3
    Thanks for the advice !
     

Share This Page