Unable to enable noatime

Discussion in 'macOS' started by ThrawnTHX, Feb 11, 2010.

  1. ThrawnTHX macrumors member

    Joined:
    Jul 20, 2009
    #1
    I have an SSD as a boot drive for my uMBP and a secondary HDD for storage. I've also changed my home folder to the HDD to minimize writes and save space via account settings.

    Here's a shameless snippet from an SSD forum on how to enable noatime, which I followed:

    "I would suggest that you instead use launchd to add the noatime option. (And this will work for those of you who may have had difficulty getting the previous hint to work.) Simply create the following text file:

    Code:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>Label</key>
    <string>com.my.noatime</string>
    <key>ProgramArguments</key>
    <array>
    <string>mount</string>
    <string>-vuwo</string>
    <string>noatime</string>
    <string>/</string>
    </array>
    <key>RunAtLoad</key>
    <true/>
    </dict>
    </plist>

    Save this file using the same name you used in the file with a .plist extension. For example, using the sample code above, you would save this file as "com.my.noatime.plist". (I've attached a copy of this file in case you don't want to create it on your own.)

    The file needs to be owned by root and placed within the correct directory so that launchd will find and execute it. To do this, open a terminal window, change to the directory where you saved this file, and execute the following commands:

    Code:

    sudo chown root:wheel com.my.noatime.plist
    sudo mv com.my.noatime.plist /Library/LaunchDaemons/


    I did this, rebooted, and typed "mount" in terminal, but I'm not showing noatime. Any suggestions on how to get this to work?
     
  2. ThrawnTHX thread starter macrumors member

    Joined:
    Jul 20, 2009
    #2
    In case it helps anyone troubleshoot this for me, I figured I'd provide some additional information. I successfully enabled noatime on my 13' MBP by following the above instructions, however it still won't work on my 17' MBP.

    I'm wondering if it has something to do with my 17' having two hard drives with the home folder located off the boot drive. Any ideas? Noatime does not show in terminal following "mount" or in Console.
     
  3. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #3
    What if you create two files, one for each volume?
     
  4. ThrawnTHX thread starter macrumors member

    Joined:
    Jul 20, 2009
    #4
    I thought of that, but I don't see how that's possible considering that the plist file must be owned by root and is contained in Library/LaunchDaemons which is on my boot drive (the SSD).
     
  5. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #5
    Create two of them and place them in the same directory with the same permissions. I don't believe the filename is important to the OS.
     
  6. ThrawnTHX thread starter macrumors member

    Joined:
    Jul 20, 2009
    #6
    I think you might be on to something. Would you suggest "sudo chown root:wheel" on the second copy as well?
     
  7. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #7
    Certainly. That will set the owner/group the same. You might want to check the permissions as well, based on other files in that directory.
     
  8. ThrawnTHX thread starter macrumors member

    Joined:
    Jul 20, 2009
  9. liuman51086 macrumors newbie

    Joined:
    Sep 30, 2010
    #9
    Sorry to bring up the dead, but I am having the same problem still.

    I have my ssd as my main drive, and another hard drive, but unlike the OP, I don't have the home folder set to the hdd.

    When I type mount, I get this:

    /dev/disk1s2 on / (hfs, local, journaled)
    devfs on /dev (devfs, local, nobrowse)
    /dev/disk0s2 on /Volumes/Macintosh (hfs, local, journaled)
    /dev/disk0s3 on /Volumes/BOOTCAMP (ntfs, local, read-only, noowners)
    map -hosts on /net (autofs, nosuid, automounted, nobrowse)
    map auto_home on /home (autofs, automounted, nobrowse)

    I have made 2 plist files with the code in the LaunchDaemons folder, both with root:wheel as the owner through chown, and all permissions are same as other plist files.

    I have <string>com.my.noatime</string> in the 2nd one edited to be my2 to coordinate with the 2nd plist file name.

    At first I thought since mount showed 3 disks, I should add 3 plists in there, but still no go. Any thoughts?

    Thanks!
     

Share This Page