Unable to format hard drive

Discussion in 'MacBook Pro' started by pcgolfer85, Nov 22, 2009.

  1. pcgolfer85 macrumors member

    pcgolfer85

    Joined:
    May 19, 2008
    #1
    Hello,

    I am having issues with formatting my main drive in my Macbook Pro (mid 2009) to install Leopard.

    I have booted off of several Leopard and Snow Leopard install discs and attempted to use Disk Utility to format my drive. Everytime I try to format the drive I get one of two errors: 1. input/output error OR 2. Unable to allocate memory.

    I have tried using several hard drives.

    What the heck is going on here?

    Any help would be much appreciated.
     
  2. gmanterry macrumors regular

    gmanterry

    Joined:
    May 31, 2008
    Location:
    Phoenix, AZ
    #2
    The problem is probably the partition.

    You need to have a GUID partition for OSX Tiger and above. Just start up Disk Utility and select the drive and then partition and then options. You will be presented with three partition options; GUID, Apple Partition and Master Boot Record. Select the GUID Partition and select Apply. After that is done you should be able to format your drive. I hope this helps.

    Terry
     
  3. pcgolfer85 thread starter macrumors member

    pcgolfer85

    Joined:
    May 19, 2008
    #3
    Thank you for responding. I forgot to mention that I was selecting a GUID partition before attempting to format. It turns out that it is a bad logic board. Has anymore had this happen to them?
     
  4. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #4
    Run the apple hardware Test and see if there's any issues with your laptop.

    Sounds like you're incurring some sort of hardware problem that is preventing you from formatting the drive.
     
  5. pcgolfer85 thread starter macrumors member

    pcgolfer85

    Joined:
    May 19, 2008
    #5
    Thank you. I am having a heck of a time get the machine to boot of the diagnostic disc. I am holding down "D" but the machine keeps on ignoring the disc. :mad:

    I'll keep plugging away at it and post updates as they come in.
     
  6. aarond12 macrumors 65816

    aarond12

    Joined:
    May 20, 2002
    Location:
    Dallas, TX USA
    #6
    Try booting up holding down the Option key. This will bring up a menu of all your bootable volumes.

    -Aaron-
     
  7. MikeSantor macrumors regular

    Joined:
    Jun 9, 2009
    Location:
    Chicago, Dirty South.
    #7
    I wish I had some more info to help you out but Ill share a quick story.

    About 3 months ago I got my first Mac And I purchased the WD 500GB drive off the bat. After researching it seemed like EVERYONE that upgraded there boot disk would just take out there old disk, put in the blank disk and partition and install from the DVD.

    I got all the errors you got and then some. It wouldn't let me do anything. It would hang, etc. I posted all the issues like your doing and everyone said that there had to be something else wrong because i was getting too wide a range of errors. Like some of the errors weren't even HDD related.

    Someone finally came in and said try booting from your old drive, Put the blank/new disk in an external case and partition. Then restart (with the new disk still external), run the DVD and install to the internal disk.

    For some reason this worked like a Charm. After OS X was installed externally I swapped the drives and everything was gravy. It was VERY weird.


    .02

    Good Luck Buddy.
     
  8. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #8
    Sounds like failed hardware.

    Take it to the Apple Store, an Apple Authorized Service Provider, or call AppleCare to request mail-in service.

    www.tinyurl.com/findaasp to find your nearest service provider.
     
  9. pcgolfer85 thread starter macrumors member

    pcgolfer85

    Joined:
    May 19, 2008
    #9
    I figured it out...

    It turns out it was the hard drive/sleep indicator cable. I was unable to format the new hard drive due to the poor itegrity of the cable that connects the hard drive to the motherboard.

    I discovered this because Apple diagnostics kept giving me error codes that indicated a bad hard drive. It did this even with brand new hard drives. So, I started with the smallest part and worked my way up the chain.

    I replaced the cable with a new one and the machine booted properly. weird...

    Thank you everybody for all your assistance.

    I like this forum. :D
     
  10. Heavenly macrumors member

    Heavenly

    Joined:
    Sep 16, 2009
    Location:
    Northwestern University
    #10
    Yep, I/O error definitely means it's a bad hard drive :(
     
  11. pcgolfer85 thread starter macrumors member

    pcgolfer85

    Joined:
    May 19, 2008
    #11
    Uhhh...read above. I figured it out. It wasn't a bad hard drive. It was a bad hard drive/sleep indicator cable.

    Please read what was posted before posting a new comment.
     

Share This Page