Unable to Format/Use Transcend's 8GB Flash Drive

Discussion in 'Mac Basics and Help' started by preshit, Sep 18, 2009.

  1. preshit macrumors newbie

    Sep 7, 2009
    Hey folks,

    I was recently gifted an 8gig Transcend Flash Drive by a friend. When I inserted the drive into my unibody MacBook Pro running Snow Leopard, it pops up a window that says:

    The disk you inserted was not readable by thing computer

    Initialize / Ignore / Eject

    Clicking on Initialize takes me to Disk utility and if I try to format the drive. it gives me an error that says:

    Partition failed - POSIX reports: Cannot allocate memory.

    I then take the drive to a Mac that's running Leopard, but the same thing happens there as well, except the error when formatting tells me it's an 'Input / Output error'

    On both the Macs, I've tried formatting with a GUID and MBR, but neither works. I've tried to format it as Free Space/MS-DOS format or even the native Mac OS Extended, but nothing works.


    Now, before you come to the conclusion that it may be a faulty thumb drive, I need to tell you that the drive works perfectly fine on a PC. I've tried it on 3 different PCs, running XP, 7 and Ubuntu respectively. All the tree are capable of detecting, mounting the drive and read/write it just fine. I could even format the drive just fine on all three computers.

    What's more, I installed Mac Drive on a XP machine and it could format the drive as HFS+ too.

    This thing is driving me nuts for the past 12 hours and I'm out of solutions what to do.

    Any help would be really appreciated.


  2. Verdanice macrumors regular

    Aug 13, 2007
    I'm having the same issue, with multiple drives.. one or two USB keys over the last couple weeks I've had to unplug/replug 2-3 times before they mount, and I have three external hard drives two of which won't mount at all (the error you outlined) and one was touchy for a week or so and now won't mount like the others, and that's as a problem as the latter is my Time machine disk.

    Help would be greatly appreciated, I'd never had these problems under 10.5 working with a ton of USB flash drives and external hard drives.
  3. miles01110 macrumors Core


    Jul 24, 2006
    The Ivory Tower (I'm not coming down)
    What happens if you format as NTFS or FAT on a windows machine and then plug it into your Mac?
  4. preshit thread starter macrumors newbie

    Sep 7, 2009
    It throws up the same error message wanting me to 'Initialize' it or Eject it.
  5. Consultant, Sep 21, 2009
    Last edited: Jan 17, 2011
  6. Buzz Bumble Guest

    Oct 19, 2008
    New Zealand
    It could be that the drive needs more power - if you're using the keyboard USB ports on a desktop Mac (or external laptop keyboard), try plugging it directly into the computer's own USB ports.
  7. thunderino macrumors newbie

    Sep 26, 2009
    USB 8gig

    Hello, I've got the same problem with the same pen drive on a 10.4.11 powerbook.
  8. ncmason macrumors regular


    Feb 27, 2007
    I have never had problems using SanDisk USB drives. You may want to try using one of those instead.
  9. oldefixuser macrumors newbie

    Sep 28, 2009
    usb problems

    I am having some wonky things go on here...

    dual layer disks burn fine
    single layer dvd disks burn fine if using a small .dmg
    single layer dvd disks fail near end of burn if using a large .dmg file

    I've experienced a couple of errors while formatting two of my usb keys (128mb and a 512mb) that I want to install chameleon 2.0rc2 with the rc3 upgrade (an excellent boot loader that I prefer over using apple's bootcamp). I eventually managed to get them to format... persistence, i guess. Neither key had been used for maybe 4 or 5 months if that makes a difference.

    The reason that I mentioned the above problems, is to let you know that when I try to install chameleon on a single partition usb key (both 128mb or 512mb), the install fails right near the end.

    I am wondering if all of these problems and the ones you are having aren't an apple issue rather than a problem created on our respective ends.

    I have seen users in the osx86 community complaining of similar issues. It seems to be happening to quite a few people, regardless of whether or not they are running a Mac or a Hack.

    Does this help to perpetuate conversation?

  10. ajac macrumors newbie

    Sep 24, 2009
    Same exact issue. In my case, I could to format it using the disk utility on a MAC OS boot disk and was able to write data to it. However, few days later it has started giving the same problem again.

Share This Page