Unable to Import photos to forums

scouser75

macrumors 65816
Original poster
Oct 7, 2008
1,321
146
Hi guys, I need your help please. I tried to upload some photos from my Mac's Photos library to a forum today but the Photos library was greyed out. Any idea what's gone wrong?

I've attached a screen shot below. I had to save this to my Desktop as I am able to upload from there. I just can't import from the Photos library.

Screen Shot 2019-07-06 at 11.23.39.png
 

Fishrrman

macrumors P6
Feb 20, 2009
17,182
5,536
Ok, if Photos opens, why can't you go to each pic you want to upload, then save it to the desktop?
Then when you compose your post to the forum, upload right from the desktop?

That's what I do.
I also do one other thing.
Once I've saved a pic to the desktop, I open it first in Preview.
The purpose is to adjust the size of the pic if necessary, to "get it right" for forum posting (and for viewing on a computer display that is, say, 24"-27").
 
  • Like
Reactions: scouser75

scouser75

macrumors 65816
Original poster
Oct 7, 2008
1,321
146
Ok, if Photos opens, why can't you go to each pic you want to upload, then save it to the desktop?
Then when you compose your post to the forum, upload right from the desktop?

That's what I do.
I also do one other thing.
Once I've saved a pic to the desktop, I open it first in Preview.
The purpose is to adjust the size of the pic if necessary, to "get it right" for forum posting (and for viewing on a computer display that is, say, 24"-27").
I could do that. But I'm a little concerned why all of a sudden a direct upload doesn't work. Also, the other method is a little long-winded :D