Unable to import to imovie from Sony HDR-FX1

Discussion in 'Digital Video' started by picodave, Dec 18, 2005.

  1. picodave macrumors newbie

    Dec 18, 2005
    I have an IMAC G5 running with OS X 10.4.3, and I'm using a new Sony HDR-FX1 camera.
    The first 3 movies I made worked great, but yesterday I tried importing HD video and now it won't import or even display.
    Imovie displays (HD-1080i-30) after the movie title on the top bar,when I plug in my HD camera.
    I can control the camera, through imovie, with the play, stop, fast forward and rewind buttons, and even though I see the video on my camera it won't import, or display on the computer screen.
    If I put an old non HD tape into the camera I can get it to import, (after changing the camera settings).
    I've repeatedly tried the Garage band fix, but to no effect.
    I've also tried my old, non-hd camera, which works fine.
    I also tried resetting my imovie plist, which 1 website suggested.
    This is very frustrating, Sony disavows imovie on their support site and forwards you to the Apple site.
    Apple hasn't been any help.
    I spent a lot of money hoping to be able to edit widescreen HD video and now I'm wondering if that was a good idea.
    Any ideas?
  2. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    Have you tried the options that the guy with the Panasonic who posted here yesterday did when he had a similar problem?

    He reinstalled QT and ta da, it worked. Might be worth a shot.

    Another thing to ensure is that the time on the camera is correct. If it's days out from the computer, things can just not import.
  3. picodave thread starter macrumors newbie

    Dec 18, 2005
    Sony's HDR-FX1 isn't all that compatible with Imovie HD

    I tried reinstalling Quicktime, still doesn't work.
  4. picodave thread starter macrumors newbie

    Dec 18, 2005

    I figured out what happened, I somehow switched on the I.Link Conv feature on my camera. That caused my symptoms, which mimicked the weird audio problems that people have fixed by starting Garageband.
    Sorry for giving the impression that something is wrong with the program or camera.
  5. Chards macrumors newbie

    May 20, 2009
    Thanks--Turning off I.Link on Camera fixed it.

    I was having the same problem. Searched a bunch of forums looking for answer. Turning off the I.Link feature was the key. Thanks.
  6. jbasham23 macrumors newbie

    Jan 24, 2011
    importing footage from sony hdr-fx1 to imovie 8

    cannot figure out how to import this footage from my sony hdr-fx1 to imovie 8. i know everything is a little bit out dated now but still should work. going crazy trying to figure this out please help. I tryed the whole, turning off the ilink and everything. my macbook is not even showing the camera at all when hooked up using firewire port.
  7. simsaladimbamba

    Nov 28, 2010
    What exact MacBook do you have?
    Have you tried QT Player yet to capture from the camera?
  8. jbasham23 macrumors newbie

    Jan 24, 2011
    my macbook is a 2.1 ghz core 2 duo with mac os x version 10.5.4
    i have not tryed QT yet though.

Share This Page