Unable to Increase Macintosh HD Partition Size

Discussion in 'Mac OS X Lion (10.7)' started by ZAquanimus, Aug 24, 2012.

  1. ZAquanimus macrumors newbie

    Aug 24, 2012
    Mac Info:
    Model Name: MacBook Pro
    Model Identifier: MacBookPro7,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.66 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache: 3 MB
    Memory: 8 GB
    OS 10.7.4

    Okay so my original MBP came with a 320GB HDD,
    A few months ago I was able to get a 1TB HDD that I planned to upgrade to.

    Using SuperDuper I copied everything from the 320GB HDD to the 1TB HDD.
    It's been running for 6 months with no problems whatsoever.

    Last night I noticed that I finally reached 10gigs until the 320GB Partition was full.
    Sources tell me that Disk Utility allows Partition size increases without deleting data.

    This is what Disk Utility shows me.

    I increase the partition size to 999.86GB and apply it.

    The progress bar at the bottom states that the resize is completed without a problem but it always reverts back to the original 319.21GB partition.

    And any size besides 999.86GB will give me this error.

    The only problems I've been able to find is if the HDD isn't using
    Partition Map Scheme : GUID Partition Table (Which it is)

    So I'm completely stumped. :(
  2. heisenberg123 macrumors 603


    Oct 31, 2010
    Hamilton, Ontario
    are you typing in the partition size? see if draging the bottom corner down makes a difference
  3. ZAquanimus thread starter macrumors newbie

    Aug 24, 2012
    I have tried both methods.
  4. Edie Brickell macrumors member

    Apr 22, 2010
    If you are not able to partition with the help of Disk Utility. Then try a third party software like iPartition, Stellar partition manager or Paragon partition.
    Gud Luck!!
  5. maflynn Moderator


    Staff Member

    May 3, 2009
    Did you try booting from the recovery partition to see if you can increase the partition?

    One way to resolve this problem (though extreme) is to back up your drive, reformat and restore the backup.
  6. ajostergaard macrumors newbie

    Sep 8, 2012
    Had the same problem ... Found a solution

    I did a:

    diskutil list
    and noticed that the space, which appeared free in Disk Utility, was in fact filled by an Apple_Boot partition.

    I tried deleting it but couldn't so instead I split it into one free space using:

    diskutil splitPartition disk1s3 1 free spare1 200Gb
    at which point it disappeared and life was sunny and happy again. ;)

Share This Page