Unable to inherit previous Time Machine

Discussion in 'macOS Mojave (10.14)' started by orbitalpunk, Sep 28, 2018.

  1. orbitalpunk macrumors 6502

    orbitalpunk

    Joined:
    Aug 14, 2006
    #1
    I did a fresh install of Mojave on my nMP and in the past I could reconnect my Time Machine from the previous OS without having to start over. But this time I am getting an error. Has anyone experience similar issues? Usually I can go into terminal and use the following command

    sudo tmutil associatedisk -a /

    the full command would be like this:

    sudo tmutil associatedisk -a / /Volumes/Harddrive/Backups.backupdb/Mac\ Pro/2018-09-26-235241/Macintosh\ HD

    But now I get the following error:

    Failed to gather snapshots for /Volumes/Harddrive/Backups.backupdb/Mac Pro
     
  2. Howard2k macrumors 68000

    Howard2k

    Joined:
    Mar 10, 2016
    #2
    I did a clean install and had a Time Machine volume on my NAS and it had no issue opening it directly from the GUI. No CLI. I just opened the Time Machine prefs and added the drive through there I think.

    I was really impressed how smooth that was.
     
  3. Mr.Chow macrumors member

    Mr.Chow

    Joined:
    Jan 27, 2013
    Location:
    Austria
    #3
    I'm getting the same error when I try to inherit a backup. Time machine seemed far more stable in the last beta...
     
  4. interstella macrumors regular

    interstella

    Joined:
    Sep 29, 2013
    Location:
    Suffolk, England
    #4
    After installing Mojave I took a chance and deleted my TM backups off my NAS and started again. What I have noticed is that, previously, every hourly backup had the NAS drives working furiously and noisily. With Mojave, the backup process is barely noticeable.
     
  5. Ronis_BR macrumors newbie

    Joined:
    Jun 4, 2017
    #5
    Hi @orbitalpunk,

    I am having this exactly same problem! In my case, I have a HFS+ partition in which I deleted and copied all the data to a volume inside the APFS container. In this case, I needed to associate the new volume with the old one. The command `sudo tmutil associatedisk -a ...` failed with the same error message. My only solution after trying for one hour was to format the external time machine HD and start again.
    --- Post Merged, Oct 1, 2018 ---
    I submitted a Feedback to Apple.
     
  6. Ronis_BR macrumors newbie

    Joined:
    Jun 4, 2017
    #6
    Did anyone tried this after recreating the TM in Mojave?
     
  7. RabidMacFan macrumors regular

    Joined:
    Jun 19, 2012
    Location:
    California
    #7
    I had the opposite issue. I did a fresh install of Mojave and when I plugged in my High Sierra time machine disk, it automatically started comparing the previous backup and made the adjustments in the same parent folder.

    I would have preferred that time machine started from scratch with a new backup directory.
     
  8. zikken macrumors newbie

    zikken

    Joined:
    Sep 25, 2018
    #8
    I was getting this error. I went into System Preferences > Security & Privacy > Privacy and added Terminal to the Full Disk Access panel. Worked for me. Hope it helps!
     
  9. Mr.Chow macrumors member

    Mr.Chow

    Joined:
    Jan 27, 2013
    Location:
    Austria
    #9
    Thank you for the advise. Worked for me too.
     
  10. Cal_Ed macrumors newbie

    Cal_Ed

    Joined:
    Nov 23, 2018
    #10
    Worked for me as well, thanks zikken
     
  11. eelpout macrumors regular

    eelpout

    Joined:
    Oct 30, 2007
    Location:
    Silicon Valley
    #11
    Mind if I ask which NAS you're using?
     
  12. interstella macrumors regular

    interstella

    Joined:
    Sep 29, 2013
    Location:
    Suffolk, England
    #12
    I'm using a Synology DS215j. This has worked well for me with Time Machine and for everything else I've needed it for. It's been updated since, of course, so it'll now be DS218j or possibly even 219j.
     
  13. GXWebb macrumors newbie

    GXWebb

    Joined:
    Dec 3, 2018
    #13
    Thanks zikken! It finally worked for me also.
     

Share This Page