Unable to install leopard on powermac g4 agp single CPU

Discussion in 'macOS' started by kabeer, Jul 27, 2010.

  1. kabeer macrumors newbie

    Joined:
    Jul 23, 2010
    #1
    Okay, I have a power mac g4 sawtooth single CPU. I purchased a leopard install disk for the cheapest I could find without realising that it wasn't supported on this machine officially (I didn't get snow leopard because I knew that it only supported intel). So I inserted the disk (without modifying) and after booting to it got a kernel panic beginning with "the correct driver could not be found for this platform powermac 3,1". I then tried the open firmware hack many times and the same problem occured. I also tried the guide at (http://forums.macrumors.com/showthread.php?t=371302) many times even with putting in the kexts that the guide told me to if I was getting kernel panics but to no avail. I then managed to borrow my freinds intel mac and installed it to my guid partitioned 16 gb flash drive, I then cloned it to my APM partitioned other hard disk using superduper! and when booting got the same issue, I then put in the relevant kexts from the working tiger install but again to no avail
    any advice is appreciated,
    thanks
    Kabeer
     
  2. kabeer thread starter macrumors newbie

    Joined:
    Jul 23, 2010
    #2
    The strange thing is that the tiger install and install disk worked just fine
     
  3. iThinkergoiMac macrumors 68030

    Joined:
    Jan 20, 2010
    Location:
    Terra
    #3
    Not really strange since your computer supports Tiger...

    I think cloning a drive may rewrite it's boot sector as well, hence your issue with using a GUID partitioned flash drive as the clone source. Also, since you installed it via an Intel Mac, I'm positive it installed the Intel version of Leopard (especially since you were using a GUID partitioned flash drive). So that's not helping you either. You need to try the same trick with a PPC Mac if possible.
     
  4. kabeer thread starter macrumors newbie

    Joined:
    Jul 23, 2010
    #4
    You are probably right but do you have any suggestions? If I cloned a install from a supported ppc installation to my apm partitioned flash drive would it work?
     
  5. kabeer thread starter macrumors newbie

    Joined:
    Jul 23, 2010
    #5
    I have found a solution!

    dont worry everyone I have found a solution! for future readers I will explain how I did it:
    1. I got hold of the mac os 9.2 cd that was specific to my machine
    2. I partitioned my hard drive into two partitions (one for mac os x and one for mac os) but I had to do it in the tiger install cd disk utility app because it didnt work in the mac os cd
    3. I downloaded the appropriate fw update and installed mac os 9 onto the partition
    4. I did the firmware update and hey presto! the thing actually booted up
     

Share This Page