Resolved Unable to jailbreak iphone 4

Discussion in 'Jailbreaks and iOS Hacks' started by mykweb, Dec 29, 2011.

  1. mykweb, Dec 29, 2011
    Last edited: Jan 2, 2012

    mykweb macrumors member

    Joined:
    Feb 4, 2011
    Location:
    Edinburgh
    #1
    Afternoon

    I have an iphone 4 that has previously been jailboken on ios4.

    I upgraded to ios5 when it came out and I lost my jailbreak. I am now running 5.0.1

    On Tuesday night I preformed the jailbreak on 5.0.1 and installed Cydia, all was ok but I was having issues with the phone crashing every time I opened an app.

    I backed up my data and restored the phone back to 5.01 via itunes last night. Today I am trying to jailbreak again on 5.0.1

    I have tried versions of Redsn0w 9.10b1 and 9.10b3

    Each time I get a mixture of errors

    "usb communication error"
    "unexpected error"

    I get these errors just at the point where you power the phone back on. I hold the power button it get to the 3 seconds for holding the power button then flips out.

    I have tried specifing the ispw file but still the same.

    I am using an official apple usb cable (remeber this being an issue before)

    Oh and I am doing this on a mac running lion

    Any ideas

    Mike
     
  2. Kyotoma macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #2
    DFU Restore as new back to stock iOS 5.0.1 through iTunes and then try using Redsn0w 9.10b3 to jailbreak. Before you do anything, however, plug your dock connector to usb cable into a different USB port.
     
  3. dgstan macrumors 6502a

    Joined:
    Jun 29, 2010
    #3
    Also make sure you've got the latest version of iTunes. I was having similar RS errors until I re-installed iTunes. I'm on a PC though, but good luck.
     
  4. mykweb thread starter macrumors member

    Joined:
    Feb 4, 2011
    Location:
    Edinburgh
    #4
    Managed to get the phone Jailbroken but now having a few other issues. Thanks

    Mike
     

Share This Page