"Unable to Join the Network" (WPA-PSK)

Discussion in 'iPod touch' started by cbrain, Jan 5, 2008.

  1. cbrain macrumors 65816


    Dec 9, 2006
    North-East, UK

    Today I changed my routers encryption from WEP to WPA-PSK.

    When I go and select my network in the iPod Touches Wi-Fi settings screen, I get the error "Cannot Join the Network ..." (... is where my SSID is).

    Any suggestions?

    Thanks in advance.
  2. quicklook2 macrumors 6502


    Dec 23, 2007
    lakewood, ohio

    did you try to shut off everything to reset?

    does it still work in wep?
  3. J@ffa macrumors 6502a


    Jul 21, 2002
    Behind you!
    Two options. The first, and most likely, is that the iPod Touch is still trying to connect via WEP and getting borked. What you need to do to test this is go to your network in the list, and tap the little blue button that points to the right. In there, you can see the settings for the network (DNS, etc etc). Hit the 'forget this network' option at the top, confirm, and then try and reconnect to your network. Supply the password, and all should be well.

    The second option is that whichever router you're using has an odd implementation of WPA. While unlikely, because it's meant to be a standard, it can happen. The only thing I can suggest to counter that would be to look for a firmware upgrade. If it's any kind of AirPort base station, though, I suggest the first option (which is why I put it first, in any case :D). Good luck!
  4. cbrain thread starter macrumors 65816


    Dec 9, 2006
    North-East, UK

    Thank you quicklook2 and J@ffa for your replies. :)

    An extra thank you to J@ffa, as it was his suggestion that worked!

    Thanks J@ffa! :)
  5. RamblingWreck macrumors newbie

    Dec 28, 2008
    I also had a problem connecting my Ipod Touch to my Belkin54g even though I was entering the password correctly (used WPA-PSK). It took me a couple of searches to find out that the "Forget Network" key only appears if you have already had a previous successful network connection....

    So, I disabled the WPA-PSK and established a connection for about 30 seconds. Then I disconnected, and turned the WPA-PSK security back on in the Belkin54g. Next, I selected the "Forget Network" option, then I restablished connection with the Belkin54g, and HALLAUAH, the darn thing connected !!

    I want to thank you folks for your postings. They made my 12 year old daugther VERY HAPPY (the Touch is actually hers...)
  6. Dialup macrumors newbie

    Dec 1, 2009
    At last! Have had the exasperating "unable to join network" message when trying to connect to our new wireless home network on the ipod touch for the last 3 weeks...just seen RamblingWreck's post about forgetting the network, and it's worked! Yipeeeee!! So I've registered on this site just to say thanks very much!
  7. TallTone macrumors newbie

    Dec 22, 2009
    And if none of that works, if your router is using MAC address filtering, remember to add that too... You'll find it in Settings->About->Wifi Address.

    Oh yes, and make sure that you don't accidentally enter the Bluetooth address there as they are quite similar :rolleyes:
  8. surcal macrumors newbie

    Jan 1, 2010
    It seems that it could be a hardware problem.I held my iphone touching the antenna of WIFI router, it connected to the router. I was able to use the internet in this position only. Moving away from router's antenna, internet does not works. At leaset now I can do some very urgent works on iphone without GPRS connection.I was not able to use my wifi for last six months. Done everything that was already discussed in all the forums.I am calling it solved only because, I was afraid of future unlocks will not be possible without WIFI. Uptil 3.1.2 "iphone pcsuite" could be used to install ultrasn0w directly through PC. But from 3.1.3 iphone needs to install "AFC2ADD" through cydia, before it can be recognised as a jailbreaked iphone. Atleast WIFI working. This way I can update important cydia updates and apps without having to use GPRS.
  9. mikes63737 macrumors 65816

    Jul 26, 2005
    This was solved almost 2 years ago :)
  10. liamkp macrumors 68020


    May 29, 2010
    Sorry, this is off-topic but how do i get an avatar? I'm pretty sure i qualify for one, just not sure how to get one...
  11. jazzzzdude macrumors newbie

    Sep 5, 2010
    UK, South
    didn't work for me.

    I have the same problem. I've just bought my wife an iPod Touch 3rd G. I entered the MAC address into the MAC filter table on my router and tried to connect by selecting the detected SSID and entering the WPA key. Failed. I then tried the "Other" option and entered the SSID and encryption type manually, then typed in the WPA key. Failed. Then I read this thread and set my router to open. Connected fine. Set router back to WPA-PSK (TKIP), selected network details and selected "Forget network". Rebooted iPod. Tried again by choosing "Other". Failed. I have successfully connected a linux pc, 5 windows laptops, a macbook, a Wii, a PSP and 2 HTC Desires. My WPA key is 18 characters long. Any ideas?
  12. jazzzzdude macrumors newbie

    Sep 5, 2010
    UK, South

    Well I tried it a couple more times and it worked.
  13. Confumbled macrumors newbie

    Sep 6, 2010
    I had the same problem described above, but it wouldn't accept my password. Did the reboot and it accepted the password.

    Anybody know or care to explain why it behaves that way?
  14. ramosej macrumors newbie

    Dec 21, 2010
    Similar Problem *Fixed and Theory*

    I had the same problem. Where I triple checked the password I was inputting for the WPA2 connection. I continued to get the same error. I eventually set the iPad and Wireless router back to system defaults and tested each connection one step at a time starting from unencrypted to wep to wpa2. When the wireless was unencrypted it worked fine, when I changed the encryption back to WPA2 I used the supper long randomly generated key that I have used before and was proven correct; it was un-able to connect. So to save myself the hassle of retyping that long key in I changed the key to something small and it seemed to fix the issue. My theory is that the iPad might have problems processing long keys.

    Your thoughts?
  15. Nilam macrumors newbie

    Jun 17, 2011
    Thanks! Apparently the iPhone4 has a limitation on key length. I had precisely your problem. Nothing I tried worked...... Reading your post, I then shortened my key and was able to connect. Apple should fix this and enable stronger encryption/security. Minimally, they should document the issue so as not to frustrate their customers and waste their time.
  16. dbny9 macrumors newbie

    Dec 8, 2011
    With WPA2, Caps vs Lower Case Matters

    No limitation on key length in iPhone4

    I had the same problems switching my Netgear router from WEP to WPA2. I've had my 26 character hex password on my iPhone4 from the start and used the same for WPA2, so I knew it wasn't a typo. I followed all the instructions above, but nothing worked, so I began debugging from there. I started by setting my router WPA2 password to 12345678. Connected! Then I made it 12345678a. Connected. Then I made it 12345678aB but entered 12345678ab. Unable to join! I switched my 26 character password on the phone to all caps, returned my router to the same password in WPA2, and Connected!

    I know from over 30 years of programming mainframes that the hex codes for caps and lower case are different, but I've never seen it make a difference with routers/phones before. Evidently, WPA2 makes use of the difference.
  17. TwoSim macrumors newbie

    Apr 15, 2012
    You can find the ansower here:

    I tried it , and it works!

Share This Page