Unable to launch Civilization IV

Discussion in 'Mac and PC Games' started by docseuss68, Mar 2, 2008.

  1. docseuss68 macrumors newbie

    Joined:
    Mar 1, 2008
    #1
    Bought a new copy of Civilization IV, but continue to receive message “application quit unexpectedly” when attempting to launch. Running 10.5.2 on new dual quad-core mac pro with NVIDIA 8800GT and 4 gigs ram. Have been exchanging emails with Aspyr tech support without luck, and they continue to say it should run fine.

    Things suggested and tried:
    1. Successfully patched - 1.74
    2. Attempted “Open with Rosetta”
    3. Verified HD format “non-case specific”
    4. Reinstall: drag and drop into application folder

    Any other ideas?
     
  2. cmkl macrumors newbie

    Joined:
    Mar 4, 2008
    #2
    I had been playing Civ IV on my Mac Pro (2 x 3Ghz, with 4GB RAM) happily until today when I changed boot drives to a 1TB drive.

    Wonder if it's the disk's size?

    Reinstalling, patching and re-patching didn't help.
     
  3. docseuss68 thread starter macrumors newbie

    Joined:
    Mar 1, 2008
    #3
    My boot disk is a 3rd party 500gb Seagate Barracuda, but have also tried after booting from the Apple installed WD 500gb. Latest email from tech support asked again if I had a "case specific" formatted disk, and indicated the problem may be with the 8800 graphic card, but was not able to verify because he currently did not have access to one. Have become very reluctant to buy different game, fearing the same issue.
     
  4. grossimassi macrumors newbie

    grossimassi

    Joined:
    Jun 26, 2007
    #4
    its something about with Rosetta
    cant play on MBP, disk size doesn't matter
     
  5. maccanuck2006 macrumors member

    Joined:
    Aug 27, 2006
    Location:
    Vancouver Canada
    #5
    Try turning off AA. Civ IV predictably crashed just after the initial splash screen whenever AA was turned on. It runs fine without it.

    MBP 15" 2.4Ghz with 8600M and 4gigs RAM running 10.5.2
     
  6. cmkl macrumors newbie

    Joined:
    Mar 4, 2008
    #6
    Re-apply 10.5.2 cumulative upgrade

    I re-downloaded and re-applied the 10.5.2 cumulative patch, restarted my machine and was then able to get Civ IV to run.

    I had also trashed the plist files and re-installed and re-patched, so my prefs were gone. I had done that before and been unable to launch the Civ IV application so I am pretty sure it was the 10.5.2 re-patch that did it.

    I'm so much calmer now.

    cmkl
     
  7. Citizenbushido macrumors newbie

    Joined:
    May 24, 2008
    #7
    HELP PLEASE

    I'm getting ...The application Civilization IV quit unexpectedly.
    I've looked as much as I can but cant find much info on what to do.

    "Try turning off AA."

    I have no clue what AA is...can you please tell me what that is so I can try it.

    And how do I get rid of my plist files?

    Sorry I'm new to mac any advice would be helpfull
     
  8. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
    #8
    AA = antialiasing. Makes things look smoother.

    As for the .plist, I'm not actually sure where it is. Anybody else?
     

Share This Page